Bug 253433 - gpsd-devel missing gpsd_config.h
gpsd-devel missing gpsd_config.h
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gpsd (Show other bugs)
7
All Linux
urgent Severity low
: ---
: ---
Assigned To: Matthew Truch
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-19 08:58 EDT by Chitlesh GOORAH
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version: 2.34-5.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-24 01:40:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chitlesh GOORAH 2007-08-19 08:58:41 EDT
Description of problem:
gpsd-devel is missing gpsd_config.h. The /usr/include/libgpsmm.h includes 
gpsd_config.h among its headers.

/usr/include/libgpsmm.h:13:25: error: gpsd_config.h: No such file or directory
rpm -qf /usr/include/libgpsmm.h
gpsd-devel-2.34-4.fc7

It is an easy fix, but packages building against gpsd-devel fail.
There is an upstream release of "marble" (which I'm packaging) which now needs 
to be built against gpsd-devel. Right now, without gpsd_config.h 
at /usr/include/ it doesn't build.

Thus this bug blocks the updates of marble to the 0.4 version. I hope you will 
consider updating gpsd very soon. The gpsd_config.h is already included among 
gpsd sources.


Version-Release number of selected component (if applicable):
gpsd-devel-2.34-4.fc7

How reproducible:
Every time
Comment 1 Matthew Truch 2007-08-19 09:34:53 EDT
At first I was amazed that I missed this, but then I see that gpsd_config.h is
only needed by the C++ wrapper.  Whoops.  

Fixed in rawhide (when it hits the mirrors etc.), fix building for F7 and will
be pushed soon, upstream notified of their omission from make install.  
Comment 2 Chitlesh GOORAH 2007-08-19 09:39:51 EDT
Thanks.

By the way do you have some gpx files at your disposal? (I need gpx to test 
marble's new feature)
Comment 3 Matthew Truch 2007-08-19 09:47:16 EDT
(In reply to comment #2)
> By the way do you have some gpx files at your disposal? (I need gpx to test 
> marble's new feature)

Sorry, I don't have any lying around.  
Comment 4 Fedora Update System 2007-08-19 11:14:28 EDT
gpsd-2.34-5.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
Comment 5 Chitlesh GOORAH 2007-08-21 16:02:04 EDT
Can you push the same release for FC6 please ?
Marble (requiring gpsd-devel) was intended to release on FC6 as well.
Comment 6 Matthew Truch 2007-08-21 16:18:55 EDT
(In reply to comment #5)
> Can you push the same release for FC6 please ?
> Marble (requiring gpsd-devel) was intended to release on FC6 as well.

Building now; should be on the servers soon.  
Comment 7 Fedora Update System 2007-08-24 01:40:39 EDT
gpsd-2.34-5.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.