Bug 253436 - Updating kdebindings via Package Updater caused pirut exception
Summary: Updating kdebindings via Package Updater caused pirut exception
Status: CLOSED DUPLICATE of bug 253394
Alias: None
Product: Fedora
Classification: Fedora
Component: pirut   
(Show other bugs)
Version: 7
Hardware: i386
OS: Linux
low
low
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-08-19 15:21 UTC by John Rehmert
Modified: 2007-11-30 22:12 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-20 18:05:45 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description John Rehmert 2007-08-19 15:21:29 UTC
Component: pirut
Summary: TB253c984a depsolve.py:574:_requiringFromTransaction:IndexError: list
index out of range

Traceback (most recent call last):
  File "/usr/sbin/pup", line 409, in _apply
    self.applyChanges(self.mainwin)
  File "/usr/lib/python2.5/site-packages/pirut/__init__.py", line 734, in
applyChanges
    self.checkDeps(mainwin)
  File "/usr/lib/python2.5/site-packages/pirut/__init__.py", line 493, in checkDeps
    (result, msgs) = self.buildTransaction()
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 540, in
buildTransaction
    (rescode, restring) = self.resolveDeps()
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 885, in resolveDeps
    (checkdep, missing, conflict, errormsgs) = self._processReq(dep,
prcoformat_need)
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 334, in _processReq
    requirementTuple, errormsgs)
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 469, in
_requiringFromInstalled
    return self._requiringFromTransaction(reqpkg, requirement, errorlist)
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 574, in
_requiringFromTransaction
    reqpkg = self.tsInfo.matchNaevr(name=name, ver=version, rel=release)[0]
IndexError: list index out of range

Local variables in innermost frame:
requirement: ('perl(DCOP)', 0, '')
checkdeps: 0
dbpkgs: []
pkg: kdebindings-dcopperl - 3.5.7-1.fc7.1.i386
missingdep: 0
self: <__main__.PackageUpdater object at 0x8c2434c>
tspkgs: []
needname: perl(DCOP)
version: 3.5.7
needflags: 0
needversion: 
errorlist: []
pkgmode: None
a: i386
e: 0
name: kdesdk
n: kdebindings-dcopperl
r: 1.fc7.1
v: 3.5.7
release: 7.fc7
requiringPkg: ('kdesdk', '3.5.7', '7.fc7', None)
tsState: None
provSack: <yum.packageSack.ListPackageSack object at 0x902540c>

Comment 1 Jeremy Katz 2007-08-20 18:05:45 UTC

*** This bug has been marked as a duplicate of 253394 ***


Note You need to log in before you can comment on or make changes to this bug.