Bug 253444 - Live CD installation: file not found ./region
Live CD installation: file not found ./region
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
7
All Linux
medium Severity medium
: ---
: ---
Assigned To: Chris Lumens
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-19 13:23 EDT by Patrice Guay
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-22 10:48:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Patrice Guay 2007-08-19 13:23:40 EDT
Description of problem:
During an installation from a Live CD, I encountered an unhandled exception

Traceback (most recent call first):
  File "/usr/share/system-config-date/timezone_map_gui.py", line 252, in
read_regions
    fd = open (regions, "r")
  File "/usr/share/system-config-date/timezone_map_gui.py", line 215, in __init__
    self.read_regions (regions)
  File "/usr/lib/anaconda/iw/timezone_gui.py", line 77, in timezone_widget_create
    viewportWidth=viewportWidth)
  File "/usr/lib/anaconda/iw/timezone_gui.py", line 63, in custom_widget_handler
    return handler(str1, str2, int1, int2)
IOError: [Errno 2] No such file or directory: './regions'
[...]

Version-Release number of selected component (if applicable):
anaconda 11.2.0.66-1
system-config-date 1.8.12-1.el5

How reproducible: always


Steps to Reproduce:
1. # liveinst
2. Go through the wizard until you reach the timezone selection screen
3. unhandled exception
  
Actual results:
The installation process fails

Expected results:
The installation process should succeed

Additional info:
See http://pastebin.com/f319289db for the complete traceback
Comment 1 Patrice Guay 2007-08-19 23:12:21 EDT
I tried using system-config-date 1.9.0-1 and it solved the problem. Hence, it
points to an indirect dependency problem:

anaconda-runtime 11.2.0.66 requires system-config-date >= 1.9.0
Comment 2 Chris Lumens 2007-08-22 10:48:49 EDT
This will be fixed in the next build of anaconda.  Thanks for the report.

Note You need to log in before you can comment on or make changes to this bug.