Bug 253450 - pm-utils doesn't process hooks in /etc/pm/hooks
Summary: pm-utils doesn't process hooks in /etc/pm/hooks
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: pm-utils (Show other bugs)
(Show other bugs)
Version: 7
Hardware: All Linux
low
low
Target Milestone: ---
Assignee: Phil Knirsch
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-08-19 19:46 UTC by James Ettle
Modified: 2015-03-05 01:19 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-19 19:49:40 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description James Ettle 2007-08-19 19:46:29 UTC
Description of problem:
Hooks placed in /etc/pm/hooks/ (such as by the 915resolution package) are not
processed during hibernate/thaw suspend/resume cycles.

Version-Release number of selected component (if applicable):
pm-utils-0.99.3-8.fc7

How reproducible:
Always.

Additional info:
Hooks in /etc/pm/sleep.d/ *are* processed. The problem traces to line 84 (in the
run_hooks function) of /usr/lib/pm-utils/functions which globs only sleep.d
files and not those in the hooks/ directory.

Comment 1 James Ettle 2007-08-19 19:49:40 UTC
Ignore this, the bug should be reported in 915resolution (to move the location
of its hook) since /etc/pm/hooks is no longer part of pm-utils.


Note You need to log in before you can comment on or make changes to this bug.