Bug 253454 - segfault on 2.6.22.1-41.fc7
segfault on 2.6.22.1-41.fc7
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: procinfo (Show other bugs)
7
i686 Linux
high Severity low
: ---
: ---
Assigned To: Tomas Smetana
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-19 16:18 EDT by Łukasz Trąbiński
Modified: 2008-01-14 03:33 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-14 03:33:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
You can see problem on this output from command line (32.87 KB, text/plain)
2007-08-19 16:18 EDT, Łukasz Trąbiński
no flags Details

  None (edit)
Description Łukasz Trąbiński 2007-08-19 16:18:57 EDT
Description of problem:

Many programs doesen't work correctly and they finish with:
Segmentation fault

Version-Release number of selected component (if applicable):

2.6.22.1-41.fc7

How reproducible:

update kernel from 2.6.21-1.3194.fc7 to 2.6.22.1-41.fc7 from fedora update
type on terminal: procinfo
innd also dosen't work correctly:

[root@node2 log]# cat messages |grep segfault
Aug 19 21:35:14 node2 kernel: procinfo[20720]: segfault at 00007fffdb253ff4 rip
0000000000403c14 rsp 00007fffdb247ab0 error 4
Aug 19 21:37:16 node2 kernel: procinfo[20742]: segfault at 00007fff274321e4 rip
0000000000403c14 rsp 00007fff27425ca0 error 4
Aug 19 21:45:16 node2 kernel: procinfo[20759]: segfault at 00007ffff7fbbd64 rip
0000000000403c14 rsp 00007ffff7faf820 error 4
Aug 19 21:47:41 node2 kernel: procinfo[1898]: segfault at 00007fff5c7fdc84 rip
0000000000403c14 rsp 00007fff5c7f1740 error 4
Aug 19 21:48:21 node2 kernel: procinfo[1903]: segfault at 00007fffaa049d94 rip
0000000000403c14 rsp 00007fffaa03d850 error 4
Aug 19 22:04:02 node2 kernel: procinfo[1906]: segfault at 00007fff41513454 rip
0000000000403c14 rsp 00007fff41506f10 error 4
Aug 19 22:08:13 node2 kernel: procinfo[1928]: segfault at 00007fffa3b478a4 rip
0000000000403c14 rsp 00007fffa3b3b360 error 4
Aug 19 22:11:20 node2 kernel: procinfo[1937]: segfault at 00007fff697454a4 rip
0000000000403c14 rsp 00007fff69738f60 error 4


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Kernel 2.6.21-1.3194.fc7 works correctly without this problem
Comment 1 Łukasz Trąbiński 2007-08-19 16:18:57 EDT
Created attachment 161825 [details]
You can see problem on this output from command line
Comment 2 Sammy 2007-08-20 10:14:39 EDT
I can confirm the segfault with kernel  2.6.22.3-61.fc7 as well EXCEPT on
my two core i386 system "Intel(R) Pentium(R) 4 CPU 3.06GHz". All my other
systems are Core 2 or Core 2 Quad x86_64 systems and procinfo segfaults
while examining something with the cpu's (seen from a simple strace output).
Comment 3 Sammy 2007-08-20 10:58:54 EDT
The crash seems to be happening at line 470 of proc. I am not a c programmer
but if I blindly make the change
             irq_label[i][0] ---> irq_label[i]
at line 470 than there is no crash. Hope this helps.


Here is the backtrace:
===============================================================================
# gdb procinfo
GNU gdb Red Hat Linux (6.6-15.fc7rh)
Copyright (C) 2006 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "x86_64-redhat-linux-gnu"...
Using host libthread_db library "/lib64/libthread_db.so.1".
(gdb) run
Starting program: /usr/bin/procinfo

Program received signal SIGSEGV, Segmentation fault.
0x0000000000403c44 in first_page (sl=<value optimized out>) at procinfo.c:470
470                     if (irq_label[i][0] == 0)
(gdb) bt
#0  0x0000000000403c44 in first_page (sl=<value optimized out>) at procinfo.c:470
#1  0x00000000004054d9 in main (ac=1, av=0x7ffffa776ca8) at procinfo.c:907
#2  0x0000003dc841dab4 in __libc_start_main () from /lib64/libc.so.6
#3  0x00000000004018e9 in _start ()
==============================================================================
Comment 4 Christopher Brown 2007-09-25 11:51:02 EDT
Hello,

I'm reviewing this bug as part of the kernel bug triage project, an attempt to
isolate current bugs in the fedora kernel.

http://fedoraproject.org/wiki/KernelBugTriage

I am CC'ing myself to this bug and will try and assist you in resolving it if I can.

There hasn't been much activity on this bug for a while. Could you tell me if
you are still having problems with the latest kernel?

If the problem no longer exists then please close this bug or I'll do so in a
few days if there is no additional information lodged.
Comment 5 Łukasz Trąbiński 2007-10-01 03:49:51 EDT
I have just upgraded kernel from FC7 updates to 2.6.22.9-91.fc7 and it look like
before upgrade:

[root@node2 ~]# uname -r
2.6.22.9-91.fc7

[root@node2 ~]# procinfo 
Naruszenie ochrony pamięci

[root@node2 ~]# dmesg 
procinfo[1878]: segfault at 00007fffa76f6464 rip 0000000000403c14 rsp
00007fffa76e9f20 error 4
Comment 6 Christopher Brown 2007-10-01 05:32:12 EDT
If you boot with:

acpi=noirq

does the error still occur? I take it that this is not just happening with procinfo.
Comment 7 Łukasz Trąbiński 2007-10-01 06:14:04 EDT
With error still occurs.
[root@node2 ~]# cat /proc/cmdline 
ro root=LABEL=/ acpi=noirq
[root@node2 ~]# procinfo 
Naruszenie ochrony pamięci
Comment 8 Christopher Brown 2007-10-01 06:57:47 EDT
Is this just happening with procinfo only? Can you give examples of other
applications giving the same error?
Comment 9 Łukasz Trąbiński 2007-10-01 07:34:46 EDT
for example: nnrp, expireover
Comment 10 Christopher Brown 2007-10-01 08:31:53 EDT
So why do you think this is a kernel bug? You might have a broken glibc which
you are building against. I'm no programmer but I fail to see how this relates
to the kernel.
Comment 11 Christopher Brown 2008-01-11 12:19:23 EST
Hello Lukasz,

As I can't see this being a kernel-related issue, I'm tempted to close NOTABUG
or change the component to procinfo. These applications are segfaulting, not the
kernel.
Comment 12 Christopher Brown 2008-01-11 12:25:19 EST
Changing component...
Comment 13 Jon Stanley 2008-01-11 13:17:11 EST
your forgot to hit the reassignment button :)
Comment 14 Tomas Smetana 2008-01-14 03:05:26 EST
Can't reproduce with kernel-2.6.23.12-52.fc7 and procinfo-18-21.fc7.  What
version of procinfo do you use?
Comment 15 Łukasz Trąbiński 2008-01-14 03:14:03 EST
Well, I have upgraded my servers to FC8, now I don't see this problem.
Comment 16 Tomas Smetana 2008-01-14 03:33:05 EST
Hm...  There was an update of procinfo due to segfaulting so chance is that you
didn't have that installed on your F-7.  Let's close this bug.

Note You need to log in before you can comment on or make changes to this bug.