Bug 253460 - Missing symlinks /usr/libexec/nx/ -> /usr/bin/
Missing symlinks /usr/libexec/nx/ -> /usr/bin/
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: freenx (Show other bugs)
7
All Linux
low Severity low
: ---
: ---
Assigned To: Axel Thimm
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-19 19:05 EDT by Reindl Harald
Modified: 2007-11-30 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-21 06:56:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Reindl Harald 2007-08-19 19:05:42 EDT
It seems that the packages does not create symlinks under /usr/bin/
So you have to create them manually before finish setup
Same with the FC6-Packages on another machine

ln -s /usr/libexec/nx/nxagent /usr/bin/
ln -s /usr/libexec/nx/nxclient /usr/bin/
ln -s /usr/libexec/nx/nxdesktop /usr/bin/
ln -s /usr/libexec/nx/nxkeygen /usr/bin/
ln -s /usr/libexec/nx/nxloadconfig /usr/bin/
ln -s /usr/libexec/nx/nxnode /usr/bin/
ln -s /usr/libexec/nx/nxnode-login /usr/bin/
ln -s /usr/libexec/nx/nxprint /usr/bin/
ln -s /usr/libexec/nx/nxproxy /usr/bin/
ln -s /usr/libexec/nx/nxserver /usr/bin/
ln -s /usr/libexec/nx/nxserver-helper /usr/bin/
Comment 1 Ignacio Vazquez-Abrams 2007-08-19 19:11:12 EDT
Why do you need them in /usr/bin?
Comment 2 Reindl Harald 2007-08-19 19:15:27 EDT
Because "nxsetup" fails to locate "nxloadconfig" and all helps you find speaks
from "nxsetup", "nxserver -adduser" and most users wont find them if they are
not in path.

If they find them "nxsetup" fails, so this is not useful :-)
Comment 3 Axel Thimm 2007-08-20 09:54:27 EDT
The packages reflect a state like what you would get after a nxsetup, e.g.
nxsetup is a script for installing stuff.
Comment 4 Reindl Harald 2007-08-20 09:59:47 EDT
You need "nxsetup" for generating your own keys or change them, adding users and
so on.

"nxsetup" does not work if it finds not some other parts

Please look at http://www.google.de/search?q=nxsetup and tell me where is the
problem to add this links in the package so that users who finds something in
google can do this also on fedora?
Comment 5 Axel Thimm 2007-08-20 13:02:27 EDT
The rpms already generate their keys at the right locations and the required
user/group. Running nxsetup on top of the Fedora customized setup is not advised
and will probably break the setup. That's also the reason why nxsetup is only
shipped as part of the docs.
Comment 6 Reindl Harald 2007-08-21 05:06:45 EDT
No
/var/lib/nxserver/home/.ssh/client.id_dsa.key is missing and sorry but nut
everyone will use the no-machine-key!

What you say is "Take it how it is and do not configure self", but thats
windows-like and not linux
Comment 7 Axel Thimm 2007-08-21 06:56:30 EDT
> What you say is "Take it how it is and do not configure self", but thats
> windows-like and not linux

No, that's the wrong interpretation. The reality is that software needs to be
adjusted to a distribution to properly blend in. nxsetup does not play along and
since the really used functionality is already covered there is no need to patch
it up. You can and should place your keys as you like, just not with nxsetup.
Every configuration option remains open to your tweaking.

Having said that, if you really want to see the nxsetup wrapper, patches are
welcome. You need to make sure that no (re)install methods can be called by the
user so he doesn't shoot his legs (or his rpms).

Looping back to the Subject:

"Missing symlinks /usr/libexec/nx/ -> /usr/bin/"

By definition one either uses bindir if the binaries are expected to be used
directly by the user or libexecdir if they are only to be used by other
binaries. Symlinking across these makes no sense. If one were to attack this
problem one would instead add the libexec path components to nxsetup.

Note You need to log in before you can comment on or make changes to this bug.