Bug 253463 - initng-ifiles hang after udev/filldev
Summary: initng-ifiles hang after udev/filldev
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: initng-ifiles   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Daniel Malmgren
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-08-19 23:57 UTC by Rudolf Kastl
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-02 12:44:04 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Rudolf Kastl 2007-08-19 23:57:21 UTC
Description of problem:
after a clean install of initng on rawhide the boot attempt hangs right after
udev/filldev was executed with default generated runlevel

Version-Release number of selected component (if applicable):
0.6.10.1 and 0.1.4

How reproducible:
always

Additional info:
just ask

Comment 1 Daniel Malmgren 2007-08-23 07:13:02 UTC
Ok, for a starters, what do you mean with "hangs"? Does it just stop or is there
any other information?

Another question that may seem somewhat irrelevant: Does the computer have any
bluetooth interface? Is it activated? (My laptop sometimes stops after the
filldev step and just waits until I activate the bluetooth interface. I've never
found out what the connection is...)

Comment 2 Rudolf Kastl 2007-08-23 07:31:18 UTC
maybe what you describe is a kinda "race" condition. with hangs i want to say
that it just hangs there and shows that as last step completed. actually there
is no additional information i can give. maybe it is a kinda dependency loop. if
you e.g. google for initng filldev hang you will see that i am not the only one
having that problem.

Comment 3 Daniel Malmgren 2007-08-23 08:43:38 UTC
One idea: Try to start initng with "interactive" argument (as kernel argument)
and see what happens. That way you'll be able to confirm every started service,
might give some more information...

Comment 4 Daniel Malmgren 2007-11-01 14:40:54 UTC
Any new input on this one, Che?

Comment 5 Rudolf Kastl 2007-11-01 15:03:04 UTC
i fixed it with the modified svn diff in the new src rpm. removed an & and also
removed the race condition that came with it.


Comment 6 Daniel Malmgren 2007-11-02 12:44:04 UTC
Ok. Since I now have built that in devel, I guess I can close this bug.


Note You need to log in before you can comment on or make changes to this bug.