Bug 253479 - [XEN-HVM]Booting two windows guests causes RHEL5.1 IA32e Xen to crash
Summary: [XEN-HVM]Booting two windows guests causes RHEL5.1 IA32e Xen to crash
Status: CLOSED DUPLICATE of bug 249409
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xen   
(Show other bugs)
Version: 5.1
Hardware: All Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Steven Rostedt
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-08-20 06:30 UTC by Zhao Yunfeng
Modified: 2009-12-14 21:12 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-14 13:00:41 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
hvm config file (7.32 KB, text/plain)
2007-08-20 06:30 UTC, Zhao Yunfeng
no flags Details

Description Zhao Yunfeng 2007-08-20 06:30:38 UTC
Description of problem:
RHEL5.1 IA32e xen will crash when boot two 32bit windows guests.


Version-Release number of selected component (if applicable):


How reproducible:
1. prapare two 32-bit Windows guest
2. create 2 32-bit window xp guest in parellel

Actual results:


Expected results:


Additional info:
Output of serial console:
output of serial console

(XEN) mtrr: type mismatch for d0000000,1000000 old: uncachable new: write-
combining
(XEN) mm.c:1345:d0 Bad L1 flags 800000
(XEN) mm.c:1345:d0 Bad L1 flags 800000
(XEN) mm.c:1345:d0 Bad L1 flags 800000
(XEN) mm.c:1345:d0 Bad L1 flags 800000
(XEN) mm.c:1345:d0 Bad L1 flags 800000
(XEN) mm.c:1345:d0 Bad L1 flags 800000
(XEN) mm.c:1345:d0 Bad L1 flags 800000
(XEN) mm.c:1345:d0 Bad L1 flags 800000
(XEN) mm.c:1345:d0 Bad L1 flags 800000
(XEN) mm.c:1345:d0 Bad L1 flags 800000
----------- [cut here ] --------- [please bite here ] ---------
Kernel BUG at mm/memory.c:2290
invalid opcode: 0000 [1] SMP
last sysfs file: /block/loop0/range
CPU 5
Modules linked in: xt_physdev loop tun nfs lockd fscache nfs_acl netloop netbk 
blktap blkbk 
ipt_MASQUERADE iptable_nat ip_nat xt_state ip_cond
Pid: 5536, comm: qemu-dm Not tainted 2.6.18-37.el5xen #1
RIP: e030:[<ffffffff80208b30>]  [<ffffffff80208b30>] 
__handle_mm_fault+0x379/0xf46
RSP: e02b:ffff8800c0369de8  EFLAGS: 00010202
RAX: ffffffff805147c0 RBX: 0000000000000130 RCX: 00003ffffffff000
RDX: 00000000c0098130 RSI: 0000000000000067 RDI: ffff8800ef5a5140
RBP: ffff8800ef5a5140 R08: 0000000000000000 R09: 0000000000000000
R10: 0000000000000001 R11: 0000000000000246 R12: 0000000000000000
R13: ffff8800c0098130 R14: 00002aaaac626000 R15: ffff8800b2cb5528
FS:  00002aaaaaad85a0(0000) GS:ffffffff80599280(0000) knlGS:0000000000000000
CS:  e033 DS: 0000 ES: 0000
Process qemu-dm (pid: 5536, threadinfo ffff8800c0368000, task ffff880000dad100)
Stack:  0000000000000001  0000000180501c28  ffff8800ef5a5140  ffff8800c030cb18
 ffffffff8028028d  0000000300000000  ffffffff80501c28  0000000000000000
 0000000000000001  0000000000000000
Call Trace:
 [<ffffffff8028028d>] __wake_up_common+0x3e/0x68
 [<ffffffff802641db>] do_page_fault+0xe48/0x11dc
 [<ffffffff80261519>] __up_wakeup+0x35/0x67
 [<ffffffff8025d823>] error_exit+0x0/0x6e


Code: 0f 0b 68 ce 50 47 80 c2 f2 08 49 8b 87 90 00 00 00 48 c7 44
RIP  [<ffffffff80208b30>] __handle_mm_fault+0x379/0xf46
 RSP <ffff8800c0369de8>
 <0>Kernel panic - not syncing: Fatal exception
 (XEN) Domain 0 crashed: rebooting machine in 5 seconds.

Comment 1 Zhao Yunfeng 2007-08-20 06:30:38 UTC
Created attachment 161845 [details]
hvm config file

Comment 3 Steven Rostedt 2007-08-20 18:15:51 UTC
How exactly was the guests started. Did you run a simple "xm create" in two
different windows?  I'm currently running two XP Guests as well as a 2003 Guest.
How much memory did each guest have (the config states 256). I'm running each of
mine with 512 (will start again with 256).

So far, I haven't had a crash.


Comment 4 Steven Rostedt 2007-08-20 19:08:28 UTC
Could you also post the config for "both" the guests that were running.

Comment 5 Zhao Yunfeng 2007-08-21 12:40:37 UTC
The config of the two windows are basically the same.
I just changed the domain name and disk images.

I create the two windows guests, with the command:
"xm cr config1;xm cr config2"

Comment 6 Steven Rostedt 2007-09-07 13:51:49 UTC
Bugzilla 249409 had the same symptom and a patch to fix it went into release -44.

Could you retest with the latest and see if the problem goes away?

Comment 8 Zhao Yunfeng 2007-09-14 06:58:53 UTC
I have retested it on snap 6.
The issue has already been fixed.


Comment 9 Stephen Tweedie 2007-09-14 13:00:41 UTC
Thanks, will close this as a dup of that other bug, then.


*** This bug has been marked as a duplicate of 249409 ***


Note You need to log in before you can comment on or make changes to this bug.