Bug 25349 - %d in format string, no argument in fetchmail
Summary: %d in format string, no argument in fetchmail
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: fetchmail   
(Show other bugs)
Version: 6.2
Hardware: i386 Linux
low
low
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-01-30 21:42 UTC by Binand Sethumadhavan
Modified: 2005-10-31 22:00 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-31 09:44:44 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Binand Sethumadhavan 2001-01-30 21:42:44 UTC
Someone on our local lug mailing list had a problem with sendmail,
so his fetchmail wasn't able to connect to the listener. The error
message he got was:

fetchmail: timeout after 134661752 seconds waiting for listener to respond.

which is obviously preposterous. The patch attached fixes this issue.

--- fetchmail-5.3.1/driver.c    Mon Mar  6 09:21:29 2000
+++ fetchmail-5.3.1.patched/driver.c    Wed Jan 31 02:20:13 2001
@@ -1503,7 +1503,7 @@
                       ctl->mda ? "MDA" : "SMTP");
            else if (phase == LISTENER_WAIT)
                report(stdout,
-                      _("timeout after %d seconds waiting for listener to respond.\n"));
+                      _("timeout after %d seconds waiting for listener to respond.\n", ctl->server.timeout));
            else
                report(stdout,
                       _("timeout after %d seconds.\n"), ctl->server.timeout);

Comment 1 Binand Sethumadhavan 2001-01-31 09:44:40 UTC
The patch I submitted is broken.

Anyway, the bug seems to be fixed in fetchmail 5.6.0.

Comment 2 Nalin Dahyabhai 2001-02-05 06:49:19 UTC
As 5.6.0 is currently in Raw Hide, I'll tag this as fixed there.  Thanks!


Note You need to log in before you can comment on or make changes to this bug.