Bug 253498 - yum-updatesd crashes when processing alerted updates
Summary: yum-updatesd crashes when processing alerted updates
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: pirut
Version: 7
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-08-20 09:59 UTC by Peter Davie
Modified: 2008-01-29 03:42 UTC (History)
2 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2008-01-29 03:42:54 UTC


Attachments (Terms of Use)
Details of the Exception log (1.75 KB, text/plain)
2007-08-20 10:04 UTC, Peter Davie
no flags Details

Description Peter Davie 2007-08-20 09:59:35 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.5) Gecko/20070718 Fedora/2.0.0.5-1.fc7 Firefox/2.0.0.5

Description of problem:
1) Alert that XX packages are updated
2) Click on "View Updates"
3) Select all, resolves dependencies : CRASH

Previously no problems.

Version-Release number of selected component (if applicable):
yum-updatesd-3.2.2-1.fc7 on kernel-2.6.22.1-41.fc7

How reproducible:
Always


Steps to Reproduce:
1. See above


Actual Results:


Expected Results:
The update process should have started and dependencies resolved.

Additional info:
Dump from exception report attached.

Comment 1 Peter Davie 2007-08-20 10:04:42 UTC
Created attachment 161860 [details]
Details of the Exception log

Comment 2 Peter Davie 2007-08-23 09:03:42 UTC
Yum at the command line works fine. Found references to a similar bug in FC6,
which was apparently fixed, yet my problem looks suspiciously similar.

http://www.redhat.com/archives/fedora-test-list/2006-July/msg00341.html

Comment 3 Peter Davie 2007-08-23 09:36:15 UTC
I've found that this is package specific- some packages cause the exception
(which occurs during "Resolving Dependencies" so it seems to be packaging issue
rather than a update daemon related one.

The ones I had to de-select to get the update to work were:
1) flac
2) fuse
3) lzo(?)

However, the "bug" is still serious since the packages affected are on the main
update server

Comment 4 Peter van Egdom 2008-01-26 13:35:52 UTC
Thank you for the report. However this has been reported to the incorrect
component. Reassigning from "up2date" to "pirut". Feel free to report any
further bugs you find to our bug tracking system.

Comment 5 Jeremy Katz 2008-01-29 03:42:54 UTC
This should be fixed with the current version of yum available in the updates repo


Note You need to log in before you can comment on or make changes to this bug.