Bug 253517 - rpm macro %{_sysconfdir} points to /usr/etc rather than /etc
rpm macro %{_sysconfdir} points to /usr/etc rather than /etc
Status: CLOSED DUPLICATE of bug 211119
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: rpm (Show other bugs)
x86_64 Linux
high Severity medium
: ---
: ---
Assigned To: Panu Matilainen
Depends On:
  Show dependency treegraph
Reported: 2007-08-20 08:22 EDT by David Blundell
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-08-20 08:34:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description David Blundell 2007-08-20 08:22:30 EDT
Description of problem:
When the x86_64 release of RHEL 5 is installed on a Xeon EM64T box, the rpm
macro %{_sysconfdir} points to /usr/etc rather than /etc This causes RPMs to be
built incorrectly.  This can be checked by the command

"rpmbuild --showrc | grep _sysconfdir.*etc"

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. install x86_64 release of RHEL4 on a Xeon EM64T box
2. use rpmbuild
Actual results:
%_sysconfdir is set to /usr/etc causing RPMs to build incorrectly

Expected results:
%_sysconfdir is set to /etc causing RPMs to build correctly

Additional info:
The cause of the problem is that the arch in /etc/rpm/platform is set to
"ia32e-redhat-linux" which causes the system to look in /usr/lib/rpm/ia32e-linux
for macro details.  The fix is to either change the arch in /etc/rpm/platform to
"x86_64-redhat-linux" or "ln -s x86_64-linux /usr/lib/rpm/ia32e-linux"
Comment 1 Panu Matilainen 2007-08-20 08:34:07 EDT

*** This bug has been marked as a duplicate of 211119 ***

Note You need to log in before you can comment on or make changes to this bug.