Bug 25355 - natsemi included in beta 3 has problems
natsemi included in beta 3 has problems
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
Florence Gold
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-01-30 17:19 EST by Edward Kuns
Modified: 2007-04-18 12:30 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-05 19:28:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Edward Kuns 2001-01-30 17:19:13 EST
The natsemi driver included in beta-3 has some problems.  The
natsemi driver in beta-2 did not have these problems.  The network
card in question is a Netgear FA-312.

All *appears* to work, but when I try to use the card, I get
dropped packets without any complaint in dmesg or /var/log/messages.
Another network card (w/ tulip driver) in the same machine works
without any problems, so I know this is a natsemi driver problem.
Comment 1 Glen Foster 2001-01-31 16:48:58 EST
This defect is considered MUST-FIX for Florence Gold release
Comment 2 Michael K. Johnson 2001-02-08 16:39:34 EST
I have purchased one of these cards for testing.
Comment 3 Trond Eivind Glomsrxd 2001-02-22 14:51:44 EST
I just bought one, and it seems to work just fine with the Wolverine kernel (and
with the current AC kernels).
Comment 4 Michael K. Johnson 2001-02-23 12:39:03 EST
Ok, I'll mark this one as closed rawhide; ekuns, please reopen if the
wolverine kernel doesn't fix it for you.
Comment 5 Edward Kuns 2001-03-10 05:30:59 EST
With Wolverine, this driver still has problems.  Intermittent
connections, slow connections.  I have a natsemi and a tulip
network card in the test machine.  FTP'ing to kilroy (the
machine from which I type this) works perfectly on the tulip
card ... but doing so with the natsemi card works on rare
occasion for small files, but pulling a kernel over hangs
partway through the kernel.  I *think* the natsemi driver
hung the machine due to my killing the ftp sessions and
starting over and over.  During this experimentation, my
machine hung, locked solid.

Yes, when switching from one network device to the other,
I swap their network addresses (192.168.1.11 and 192.168.2.11)
and the network cable by appropriate means.  (Deactivate
both, edit both, activate both.)

FYI, with my current arrangement of PCI cards, the natsemi
card is sharing its IRQ with the two USB devices on the
motherboard and with my SCSI card ... but neither is in
use with my current test configuration.  "/boot" is the
only partition on a SCSI device, and I have no USB devices
connected.
Comment 6 Edward Kuns 2001-03-10 05:39:45 EST
Forgot to mention ... 46% lost packets on a ping test.  With
the tulip card, 0% lost packets pinging the same host.
Comment 7 Trond Eivind Glomsrxd 2001-03-10 10:11:56 EST
I have 0 packet loss, successful install and no problems...

What does the relevant lines of "lspci -v" say?
Comment 8 Edward Kuns 2001-03-11 10:56:42 EST
00:0d.0 Ethernet controller: National Semiconductor Corporation: 
                                                            Unknown device 0020
        Subsystem: Netgear: Unknown device f312
        Flags: bus master, medium devsel, latency 32, IRQ 11
        I/O ports at a000 [size=256]
        Memory at df001000 (32-bit, non-prefetchable) [size=4K]
        Expansion ROM at <unassigned> [disabled] [size=64K]
        Capabilities: [40] Power Management version 2

It is detected fine, installs fine, but runs poorly.
Comment 9 Trond Eivind Glomsrxd 2001-03-12 11:00:26 EST
Can you try the latest kernel from Rawhide?
Comment 10 Edward Kuns 2001-03-12 12:39:03 EST
No luck.  With that kernel, I get "destination host unreachable"
trying even to ping.  Pinging from the other end results in 100%
packet loss.  And again, swapping eth0/eth1 addresses and then
swapping the cable gives me 100% functional connection from both
directions.

I swapped back and forth several times testing this, identical
results each time.

Sorry.
Comment 11 Bob Matthews 2001-03-14 14:08:58 EST
I'm also having problems with this card (kern=2.4.2-0.1.28):

# ifup eth5
Determining IP information for eth5...
eth5: Transmit timed out, status 358a2b60, resetting...
eth5: Transmit timed out, status 358a2b60, resetting...

# ifconfig eth5
...
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:4 dropped:0 overruns:0 carrier:0
Comment 12 Arjan van de Ven 2001-03-21 08:19:24 EST
If you do

 setpci -d 100b:0020 0x45=0

as root, does the network card start working ?
Comment 13 Michael K. Johnson 2001-07-03 15:43:21 EDT
Did the final release of 7.1 work for you?
What about the errata kernel 2.4.3-12?

Note You need to log in before you can comment on or make changes to this bug.