Bug 253598 - No cursor connecting to OSX server
No cursor connecting to OSX server
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gtk-vnc (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Daniel Berrange
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-20 15:06 EDT by Bastien Nocera
Modified: 2008-08-02 19:40 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-14 00:40:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Implement rich cursor extension (6.29 KB, patch)
2007-08-30 17:51 EDT, Daniel Berrange
no flags Details | Diff
Patch to add RichCursor + XCursor extensions (11.18 KB, patch)
2007-08-30 22:08 EDT, Daniel Berrange
no flags Details | Diff

  None (edit)
Description Bastien Nocera 2007-08-20 15:06:31 EDT
gtk-vnc-0.1.0-3.fc8 on x86_64
OXSVNC 1.71 on MacOS X 10.4.10 (iirc)

The cursor doesn't show up on the screen, but highlights/tooltips show up where
the cursor should be. Works fine with vncviewer.
Comment 1 Bastien Nocera 2007-08-26 15:23:36 EDT
Daniel, what changes would this need to vinagre to work?
Comment 2 Daniel Berrange 2007-08-26 15:32:16 EDT
I've been trying to figure out what's wrong here. The VNC server itself should
always render a cursor. The client (viewer) may or may not render a cursor at
its discretion, or it may negotiate with the server to render the server cursor
locally. GTK-VNC doesn't support local rendering of the server cursor yet, so a
well behaved server should always be rendering the cursor itself. My best guess
at this time is that this is probably a bug in the OSX VNC server - expecting
the client viewer program to always support the local cursor renderering extension.
I think the best option for a quick workaround is to unhide the local cursor
with vnc_display_set_point_local(vnc, TRUE).

I need to to continue investigating just what the real cause is though because
I'd really rather only have a server cursor visible (whether rendering locally
or remotely). Will probably have to just implement the cursor extension to VNC.
Comment 3 Daniel Berrange 2007-08-30 17:51:52 EDT
Created attachment 182241 [details]
Implement rich cursor extension

Can you give this patch a try - it implenents the rich cursor offload extension
which OSX-VNC seems to want.
Comment 4 Daniel Berrange 2007-08-30 22:08:08 EDT
Created attachment 182401 [details]
Patch to add RichCursor + XCursor extensions

This updated patch implements both the richcursor and xcursor extensions which
should be enough for any server.
Comment 5 Daniel Berrange 2007-09-14 00:40:31 EDT
Release 0.2.0 pushed to rawhide, implementing both RichCursor & XCursor extensions

Note You need to log in before you can comment on or make changes to this bug.