Bug 25362 - Florence Beta3 (Fisher) fails to install on Perc3/QC & Perc3/DC
Florence Beta3 (Fisher) fails to install on Perc3/QC & Perc3/DC
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
i386 Linux
high Severity high
: ---
: ---
Assigned To: Matt Wilson
Brock Organ
Depends On:
  Show dependency treegraph
Reported: 2001-01-30 20:23 EST by Tesfamariam Michael
Modified: 2005-10-31 17:00 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2001-03-28 18:55:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Tesfamariam Michael 2001-01-30 20:23:53 EST
When installing Florence Beta3 (Fisher) on Perc3/QC and Perc3/DC, the 
installer fails with "...IOError: [Errno 28] No space left on device..." 
message. This problem is independent of the container size (tried 9GB to 
34GB containers) on PE1400(Gecko II), PE120L (Saber), and PE4400 (Opal). 
Perc2/DC works ok.
Comment 1 Michael Fulbright 2001-01-31 13:26:23 EST
Assigning to a developer.
Comment 2 Matt Wilson 2001-01-31 23:45:51 EST
there should be a full traceback with this error.  Could you attach it to the
bug report, please?
Comment 3 Tesfamariam Michael 2001-02-01 12:43:32 EST
Following are the configurations:

1) - PE2400 + 5 9Gb HDDs + Perc3/DC  ---> RAID 5
2) - PE1400 + 2 36Gb HDDs + Perc3/DC ---> RAID 1
3) - PE4400 + 5 36Gb HDDs + Perc3/DC ---> RAID 1 & 5

We were able to install on Perc3/QC with no problem.
Comment 4 Brock Organ 2001-02-01 13:14:34 EST
This traceback was provided by email from Tesfamariam_Michael@Dell.com, thanks!

Traceback (innermost last):                                                     
  File "/var/tmp/anaconda-7.1//usr/lib/anaconda/iw/progress_gui.py", line 19,   
in run                                                                          
    rc = self.todo.doInstall ()                                                 
  File "/var/tmp/anaconda-7.1//usr/lib/anaconda/todo.py", line 1645, in         
    (p, self.intf.messageWindow, pkgTimer))                                     
  File "/var/tmp/anaconda-7.1//usr/lib/anaconda/todo.py", line 1390, in         
    self.instLog.flush ()                                                       
IOError: [Errno 28] No space left on device                                     
Local variables in innermost frame:                                             
pkgTimer: <timer.Timer instance at 95c7c68>                                     
param: (<progress_gui.InstallProgressWindow instance at 84757e0>, <method       
InstallInterface.messageWindow of InstallInterface instance at 820d098>,        
<timer.Timer instance at 95c7c68>)                                              
what: 2                                                                         
total: 0                                                                        
self: <todo.ToDo instance at 84593c8>                                           
h: <header object at 88cfe68>                                                   
amount: 0                                                                       
intf: <progress_gui.InstallProgressWindow instance at 84757e0>                  
.10: (<progress_gui.InstallProgressWindow instance at 84757e0>, <method         
InstallInterface.messageWindow of InstallInterface instance at 820d098>,        
<timer.Timer instance at 95c7c68>)                                              
messageWindow: <method InstallInterface.messageWindow of InstallInterface       
instance at 820d098>                                                            
Comment 5 Brock Organ 2001-02-01 13:16:05 EST
just to clarify,  how large were your / and /tmp filesystems?  Were either
unusually small?  (The traceback is trying to write the install log to
/tmp/install.log when it ran out of space...)
Comment 6 Tesfamariam Michael 2001-02-01 13:29:14 EST
Initially this is what we had:
/boot    32MB
/usr     4GB
/var     4GB
swap     512MB
/home    4GB
/        --grow  (this is more than enough)

Another one we tried is:
/boot    32MB
swap     512MB
/        --grow
Comment 7 Venkatesh Ramamurthy 2001-02-01 19:09:08 EST
What is the firwmare version of the RAID controller? Was the installation 
failing with PE6300 systems?
Comment 8 Matt Wilson 2001-02-02 10:42:53 EST
switch to vc2 after the traceback and type "df" and send the output.
Comment 9 Tesfamariam Michael 2001-02-23 19:38:53 EST
I have tried all firmmare 1.57 down to 1.43.
Comment 10 Glen Foster 2001-02-26 14:54:14 EST
We need a copy of this hardware here (in-house) for analysis; please ship us one
so we can analyze this problem.
Comment 11 Matt Wilson 2001-03-07 14:10:19 EST
Do you still see this problem in RC2?
Comment 12 Tesfamariam Michael 2001-03-07 15:09:34 EST
No, I don't see this issue anymore.
Comment 13 Matt Wilson 2001-03-07 15:22:41 EST
Comment 14 Tesfamariam Michael 2001-03-26 19:22:36 EST
This issue was resolved in RC2 but it is re-occuring in qa0319 and qa0322 
releases. This time it happens on PowerEdge 1550(Saber) with PERC/3DCL (Taos 
Lite). It doesn't occure in PowerEdge 1400 anymore. 
When installing the latest releases on PE1550 with PERC3/DCL (two 16GB of RAID1 
firmware 1.57), the installer terminates abnormally with signal 11 as soon 
anaconda starts. I will test if this occures with PERC3/DC (Taos) tomorrow.
Comment 15 Matt Wilson 2001-03-26 23:24:32 EST
there was a kudzu bug causing segfaults.  I'd say this is a completely different
bug than what you saw earlier with the out of space bug.
Comment 16 Matt Wilson 2001-03-27 19:12:43 EST
I'm able to install without a problem on the 1550 here with a PERC/3DC
Comment 17 Tesfamariam Michael 2001-03-28 16:33:52 EST
I have been able to install with QA0327 (kernel 2.4.2-0.1.40) on PowerEdge 1550 
with PERC3/DCL (Taos Lite). This is the same configuration that failed with the 
last two builds (QA0319 & QA0322).
The issue was occuring only on PERC3/DCL which is a similar to PERC3/DC but 
without the battery and charger. I will send you a tool that lets you switch 
from one to the other.
Comment 18 Matt Wilson 2001-03-28 17:17:56 EST
you agree that it is working OK now?
Comment 19 Tesfamariam Michael 2001-03-28 18:55:26 EST
Yes, I agree.
Comment 20 Matt Wilson 2001-03-28 19:10:39 EST
excellent, closing.

Note You need to log in before you can comment on or make changes to this bug.