This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 253652 - Yum attempting to install i386 packages when x86_64 packages are available causing package conflicts
Yum attempting to install i386 packages when x86_64 packages are available ca...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
6
x86_64 Linux
urgent Severity urgent
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-20 19:34 EDT by -M
Modified: 2014-01-21 17:59 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-21 10:20:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description -M 2007-08-20 19:34:40 EDT
Updating from FC3 i386 (possibly others) to FC6 x86_64 seems to cause some
package conflict issues and in fact appears to break YUM.

I just updated from FC3 i386 to FC6 x86_64 and am having some odd problems
particularly with YUM at the moment.

First it would be nice if someone could give me an ideal as to what i386/i686
and noarch should be expected, as it's obvious that some of those are needed, I
guess for 32-bit compatibility, but which ones?

Second when running yum check-update all I'm getting back is i386 packages,
though checking with my web browser I see that shouldn't be the case as there
are several x86_64 packages in there, ElectricFence being just one.

This is also causing package conflict when trying to update packages using Yum,
so this may be related to
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=128268

I have even tried replacing $basearch in my core repo with x86_64 and that
didn't help, also uname -a returns Linux localhost.localdomain 2.6.18-1.2798.fc6
#1 SMP Mon Oct 16 14:39:22 EDT 2006 x86_64 x86_64 x86_64 GNU/Linux

So, could someone tell me what my problem is and how to fix it please?

Thanks

Forum thread active:

http://forums.fedoraforum.org/showthread.php?t=164232
Comment 1 -M 2007-08-20 19:53:38 EDT
More info:

rpm -q ElectricFence
ElectricFence-2.2.2-20
ElectricFence-2.2.2-20.2.2

rpm -q ElectricFence --qf %{ARCH}
i386x86_64

yum check-update
Setting up repositories
Reading repository metadata in from local files

ElectricFence.i386                       2.2.2-22.fc6           updates         
GConf2.i386                              2.14.0-8.fc6           updates         
GConf2-devel.i386                        2.14.0-8.fc6           updates         
GeoIP.i386                               1.4.2-1.fc6            extras          
ImageMagick.i386                         6.2.8.0-4.fc6          updates         
ImageMagick-c++.i386                     6.2.8.0-4.fc6          updates         
ORBit.i386                               1:0.5.17-20.fc6        extras          
ORBit2.i386                              2.14.3-4.fc6           updates         
ORBit2-devel.i386                        2.14.3-4.fc6           updates         
PyQt.i386                                3.17-0.1.fc6           updates         
PyQt-devel.i386                          3.17-0.1.fc6           updates         
SDL.i386                                 1.2.11-1.fc6           updates         
SDL-devel.i386                           1.2.11-1.fc6           updates         
a2ps.i386                                4.13b-57.fc6.3         updates         
a52dec.i386                              0.7.4-8.fc6            freshrpms       
aalib.i386                               1.4.0-0.11.rc5.fc6     extras          
alsa-lib.i386                            1.0.14-0.1.rc1.fc6     updates         
alsa-lib-devel.i386                      1.0.14-0.1.rc1.fc6     updates         
alsa-tools.i386                          1.0.12-4.fc6           extras          
alsa-utils.i386                          1.0.14-0.2.rc1.fc6     updates         
alsamixergui.i386                        0.9.0-0.3.rc1.fc6      extras          
anacron.i386                             2.3-44.fc6             updates         
apr-util.i386                            1.2.8-1.fc6            updates         
apt.i386                                 0.5.15lorg3.2-10.fc6   extras          
arts.i386                                8:1.5.7-0.1.fc6        updates         
arts-devel.i386                          8:1.5.7-0.1.fc6        updates         
at.i386                                  3.1.8-85.fc6           updates         
audacity.i386                            1.3.2-8.fc6            extras          
audit.i386                               1.4.2-5.fc6            updates         
audit-libs.i386                          1.4.2-5.fc6            updates         
audit-libs-python.i386                   1.4.2-5.fc6            updates         
authconfig.i386                          5.3.12-1.fc6           updates         
authconfig-gtk.i386                      5.3.12-1.fc6           updates         
autofs.i386                              1:5.0.1-0.rc3.33       updates         
avahi.i386                               0.6.16-4.fc6           updates         


Etc............
Comment 2 Jeremy Katz 2007-08-21 10:20:53 EDT
Upgrades across arches aren't at all supported.  And having packages of both
arches available is intentional so that you can continue to run x86 apps on your
x86_64 system.  There shouldn't be conflicts in the repo and if you have
specific problems, please file them against those packages.
Comment 3 -M 2007-08-21 12:21:52 EDT
The problem appears to be due to YUM not knowing it's arch, can you tell me
where it gets it's arch info from, please?

Note You need to log in before you can comment on or make changes to this bug.