Bug 253664 - util-linux-ng fails to build
Summary: util-linux-ng fails to build
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: util-linux-ng   
(Show other bugs)
Version: rawhide
Hardware: sparc
OS: Linux
high
high
Target Milestone: ---
Assignee: Karel Zak
QA Contact: Fedora Extras Quality Assurance
URL: http://sparc.koji.fedoraproject.org/k...
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-08-21 02:24 UTC by Dennis Gilmore
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-21 10:56:54 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch for spec file fixes build (1.51 KB, patch)
2007-08-21 02:50 UTC, Dennis Gilmore
no flags Details | Diff
make sparc32bash work (933 bytes, patch)
2007-08-21 04:51 UTC, Dennis Gilmore
no flags Details | Diff

Description Dennis Gilmore 2007-08-21 02:24:20 UTC
Description of problem:
on sparc util-linux-ng fails to build.


also the sparc32bash utility seems to be missing

Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1.build in koji on sparc
2.
3.
  
Actual results:
Processing files: util-linux-ng-2.13-0.55.fc8
error: File not found: /var/tmp/util-linux-ng-2.13-0.55.fc8-root/sbin/sfdisk
error: File not found by glob:
/var/tmp/util-linux-ng-2.13-0.55.fc8-root/usr/share/man/man8/sfdisk.8*
error: File not found: /var/tmp/util-linux-ng-2.13-0.55.fc8-root/sbin/cfdisk
error: File not found by glob:
/var/tmp/util-linux-ng-2.13-0.55.fc8-root/usr/share/man/man8/cfdisk.8*

Expected results:
build succeeds 

Additional info:

Comment 1 Dennis Gilmore 2007-08-21 02:32:07 UTC
i missed that sparc32bash is there.  trying to work out why sfdisk and cfdisk 
dont get built

Comment 2 Dennis Gilmore 2007-08-21 02:49:32 UTC
looks like acording to util-linux-ng-2.13-rc3/fdisk/Makefile.in sparc is 
excluded on purpose

patch fixes building on sparc.

Comment 3 Dennis Gilmore 2007-08-21 02:50:19 UTC
Created attachment 161944 [details]
patch for spec file fixes build

Comment 4 Dennis Gilmore 2007-08-21 04:51:29 UTC
Created attachment 161946 [details]
make sparc32bash work

Comment 5 Karel Zak 2007-08-21 10:56:54 UTC
Fixed, Thanks!


Note You need to log in before you can comment on or make changes to this bug.