Bug 253669 - Error with update
Error with update
Status: CLOSED DUPLICATE of bug 253394
Product: Fedora
Classification: Fedora
Component: pirut (Show other bugs)
7
i386 Linux
low Severity low
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-20 23:18 EDT by Heath Ferry
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-21 10:21:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Pirut bug output (1.77 KB, application/octet-stream)
2007-08-20 23:18 EDT, Heath Ferry
no flags Details

  None (edit)
Description Heath Ferry 2007-08-20 23:18:46 EDT
Description of problem:
Component: pirut
Summary: TB253c984a depsolve.py:574:_requiringFromTransaction:IndexError: list
index out of range

Traceback (most recent call last):
  File "/usr/sbin/pup", line 409, in _apply
    self.applyChanges(self.mainwin)
  File "/usr/lib/python2.5/site-packages/pirut/__init__.py", line 734, in
applyChanges
    self.checkDeps(mainwin)
  File "/usr/lib/python2.5/site-packages/pirut/__init__.py", line 493, in checkDeps
    (result, msgs) = self.buildTransaction()
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 540, in
buildTransaction
    (rescode, restring) = self.resolveDeps()
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 885, in resolveDeps
    (checkdep, missing, conflict, errormsgs) = self._processReq(dep,
prcoformat_need)
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 334, in _processReq
    requirementTuple, errormsgs)
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 469, in
_requiringFromInstalled
    return self._requiringFromTransaction(reqpkg, requirement, errorlist)
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 574, in
_requiringFromTransaction
    reqpkg = self.tsInfo.matchNaevr(name=name, ver=version, rel=release)[0]
IndexError: list index out of range

Local variables in innermost frame:
requirement: ('libnoatunarts.so', 0, '')
checkdeps: 0
dbpkgs: []
pkg: kdemultimedia-extras - 6:3.5.7-2.fc7.i386
missingdep: 0
self: <__main__.PackageUpdater object at 0x98334ac>
tspkgs: []
needname: libnoatunarts.so
version: 3.5.7
needflags: 0
needversion: 
errorlist: []
pkgmode: None
a: i386
e: 6
name: kdeaddons
n: kdemultimedia-extras
r: 2.fc7
v: 3.5.7
release: 1.fc7
requiringPkg: ('kdeaddons', '3.5.7', '1.fc7', None)
tsState: None
provSack: <yum.packageSack.ListPackageSack object at 0x9b48c4c>


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Heath Ferry 2007-08-20 23:18:47 EDT
Created attachment 161945 [details]
Pirut bug output
Comment 2 Jeremy Katz 2007-08-21 10:21:09 EDT

*** This bug has been marked as a duplicate of 253394 ***

Note You need to log in before you can comment on or make changes to this bug.