Bug 253694 - Yum installonly is active when it should be disabled
Yum installonly is active when it should be disabled
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
7
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-21 06:44 EDT by Simon Andrews
Modified: 2014-01-21 17:59 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-21 08:04:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Simon Andrews 2007-08-21 06:44:09 EDT
Description of problem:
Yum will remove installed kernels even when the installonly options in yum.conf
are not set.

Version-Release number of selected component (if applicable):
yum-3.2.2-1.fc7

How reproducible:
Always


Steps to Reproduce:
1. Use default yum.conf with no installonly options specified
2. Run an update which contains a kernel
  
Actual results:
=============================================================================
 Package                 Arch       Version          Repository        Size
=============================================================================
Installing:
 kernel                  i686       2.6.22.2-57.fc7  updates-testing    16 M
Updating:
 kernel-headers          i386       2.6.22.2-57.fc7  updates-testing   657 k
Removing:
 kernel                  i686       2.6.22.1-33.fc7  installed          46 M

Transaction Summary
=============================================================================

Note that the old kernel is scheduled for removal.

Expected results:
New kernel is installed, old kernel is kept.

Additional info:
The yum.conf man page says:

installonly_limit
Number  of  packages  listed in installonlypkgs to keep installed at the same
time. Setting to 0 disables this feature. Default is ’0’.

My yum.conf doesn't contain an installonly_limit line an so should default to 0
which should disable the feature, ie all kernels should be kept.
Comment 1 Simon Andrews 2007-08-21 06:48:36 EDT
If I explicitly set installonly_limit=0 in /etc/yum.conf then I get the expected
behaviour (old kernels are not removed), so it looks like yum is just not
setting the documented default when no value is specified.
Comment 2 Seth Vidal 2007-08-21 08:04:56 EDT
Yes, it's a documentation error in the release for fedora. I added a patch to
the fedora release to enable instalonly_limit=2 by default. I neglected to add
the change to the docs. The docs change is in place now in cvs but it hasn't
been pushed to a live package.


Note You need to log in before you can comment on or make changes to this bug.