Bug 253701 - Info documentation is old and incomplete
Summary: Info documentation is old and incomplete
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: glibc   
(Show other bugs)
Version: 7
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-08-21 11:25 UTC by Rui Matos
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-21 11:54:44 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Rui Matos 2007-08-21 11:25:52 UTC
So, the info format documentation shipped in glibc-2.6-4 is old. It says:

This is Edition 0.10, last updated 2001-07-06, of `The GNU C Library
Reference Manual', for Version 2.3.x of the GNU C Library.

And it is incomplete since it doesn't document the pthread_* functions.

I've noticed that on http://www.gnu.org/software/libc/manual/ the docs are
up-to-date though they don't include pthread either. If pthread is not to be
documented there where should I look? The man pages? Are they updated with
current glibc developments?

Thanks

Comment 1 Jakub Jelinek 2007-08-21 11:54:44 UTC
It is not outdated, that date etc. match what has been last printed by GNU
at the time glibc 2.6 has been branched.  Since then a newer print has been done
and therefore
2007-07-30  Roland McGrath  <roland@redhat.com>

        * manual/libc.texinfo: Update copyrights, formatting magic, and
        @dircategory.  From Karl Berry <karl@freefriends.org>.
updated it in 2.6.90.  That doesn't mean the actual content of the documentation
is obsolete, it has updates until EOY 2006.

pthread documentation used to be a part of linuxthreads which has been dropped,
but AFAIK wasn't copyright owned by FSF and worse was helplessly outdated and
described the non-standard conforming LinuxThreads implementation, so it is not
really useful for NPTL.

NPTL is aiming to be POSIX conformant, so just use POSIX documentation,
either in the form of 3p manpages in the distro, or online
http://www.opengroup.org/onlinepubs/009695399/nfindex.html


Note You need to log in before you can comment on or make changes to this bug.