Bug 253750 - service shouldn't start by default
service shouldn't start by default
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: lm_sensors (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Phil Knirsch
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F8Target
  Show dependency treegraph
 
Reported: 2007-08-21 13:59 EDT by Jeremy Katz
Modified: 2015-03-04 20:19 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-22 15:59:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jeremy Katz 2007-08-21 13:59:16 EDT
Since you need to do configuration for lm_sensors to really be useful by
default, it probably shouldn't start by default.  lm_sensors is pulled into
default installs by hpijs->net-snmp-libs->lm_sensors and thus ends up impacting
the default boot time.
Comment 1 Hans de Goede 2007-08-21 14:10:43 EDT
Sounds reasonable to disable it by default to me, but then sensors-detect needs
to be patched to run chkconfig to enable the service upon a successfull
sensors-detect run. Any perl guru's who can help there (/me does _not_ speak
perl). If someone can whip up a quick patch to sensors-detect, I would be more
then happy to integrate it into the lm_sensors package and push a new build to
rawhide.
Comment 2 Jeremy Katz 2007-08-21 14:32:35 EDT
Something like the following should do the trick..

[katzj@aglarond ~]$ diff -u /usr/sbin/sensors-detect sensors-detect 
--- /usr/sbin/sensors-detect    2007-07-19 13:53:58.000000000 -0400
+++ sensors-detect      2007-08-21 14:29:25.000000000 -0400
@@ -5785,10 +5785,8 @@
       $i++;
     }
     print SYSCONFIG $sysconfig;
-
-    print "Copy prog/init/lm_sensors.init to /etc/init.d/lm_sensors\n".
-          "for initialization at boot time.\n"
-      unless -f "/etc/init.d/lm_sensors";
+    
+    system("/sbin/chkconfig", "lm_sensors", "on");
   }
 }
Comment 3 Hans de Goede 2007-08-22 15:59:38 EDT
Thanks, that works (verified). lm_sensors-2.10.4-2 is now building, with this
patch included and the service disabled by default, closing.

Note You need to log in before you can comment on or make changes to this bug.