Bug 253761 - Kill kudzu init script?
Kill kudzu init script?
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kudzu (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Bill Nottingham
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-21 14:53 EDT by Jeremy Katz
Modified: 2014-03-16 23:08 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-10 23:47:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeremy Katz 2007-08-21 14:53:16 EDT
Since we're not using kudzu for hardware config anymore really and are just
using it for anaconda's hardware probing, does it make sense to make the next
step and kill off the kudzu initscript?  Is there anything other than the X
reconfig on video adapter change that it's still kicking off?
Comment 1 Bill Nottingham 2007-08-29 13:40:42 EDT
network devices.
Comment 2 Jeremy Katz 2007-08-29 13:58:55 EDT
In the Magical Future, we're supposed to be having NetworkManager landing for
all, which would help that.  But then again, there's no package and we're after
the freeze now.

I thought of another thing that's handled -- the serial console inittab setup.
Comment 3 Bill Nottingham 2007-08-29 14:07:43 EDT
One of these days I'm going to write a udev helper that sets up
inittab/securetty entries.
Comment 4 Bill Nottingham 2007-08-29 14:11:49 EDT
FWIW, the main bit for networks is setting HWADDR somewhere to get naming sane.
udev has some bits we can use for this instead, but they're sort of gross (rules
written to /dev/.udev that get copied to /etc once it's r/w).
Comment 5 Bill Nottingham 2008-03-10 23:47:53 EDT
Fixed in kudzu-1.2.83-3.

Note You need to log in before you can comment on or make changes to this bug.