Bug 253774 - Potentially unredistributable due to GPL 'exception'
Potentially unredistributable due to GPL 'exception'
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: liberation-fonts (Show other bugs)
rawhide
All All
urgent Severity high
: ---
: ---
Assigned To: Caius Chance
Fedora Extras Quality Assurance
: i18n
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-21 16:26 EDT by Tim Retout
Modified: 2007-11-30 17:12 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-22 10:17:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Tim Retout 2007-08-21 16:26:50 EDT
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Tim Retout 2007-08-21 16:38:16 EDT
Erm, not a good start, I hit enter too early, sorry!

The License.txt file contains this exception to the GPL, which is also a
restriction:

(b)As a further exception, any distribution of the object code of the Software
in a physical product must provide you the right to access and modify the source
code for the Software and to reinstall that modified version of the Software in
object code form on the same physical product on which you received it.

This is an additional restriction to the GPL, so making the combination of
GPL+exception unredistributable. As part of a single, modified licence, not
called the GPL, this clause would have been fine - but because the terms refer
to the GPL, this causes problems. See this thread on the debian-legal mailing
list for even more detail:
http://www.mail-archive.com/debian-legal@lists.debian.org/msg36584.html

Now that GPLv3 has been released, it would be possible for Red Hat to change the
version the GPL to v3, and drop clause 1(b). The restrictions on trademarks
probably do not belong in the /license/, either - so please be careful there as
well.

A license change won't affect linking against any other software, because the
existing license is incompatible with the GPLv2 anyway.

I'm terribly sorry if this all sounds pedantic - but no one else will be able to
redistribute these nice fonts until the license is changed.
Comment 2 Tim Retout 2007-08-21 16:55:18 EDT
(A few gulps of caffeine later... I usually look less stupid than this, honest.)

Using GPLv3 would seem to be ideal, in fact, because it is in fact permissible
to add additional terms "Declining to grant rights under trademark law for use
of some trade names, trademarks, or service marks".

It will still likely need some sort of font exception such as the one mentioned
in the GPL FAQ:
http://www.gnu.org/licenses/gpl-faq.html#FontException

If it helps, I'll offer $beverage_of_choice?
Comment 3 Caius Chance 2007-08-21 19:37:06 EDT
Would this be relevant to you inquiries?

https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=250753
Comment 6 Tim Retout 2007-08-22 07:06:02 EDT
No, I saw that bug before; that was presumably a mistake in the COPYING file,
whereas I am saying that the existing license (License.txt + COPYING together)
is self-contradictory.
Comment 7 Tom "spot" Callaway 2007-08-22 10:17:12 EDT
Spoke to the FSF on this one specifically, and this was their response:

This is free but GPL-incompatible.  I doubt the incompatibility will cause
any trouble for you, since you're probably not making software that's a
derivative work of the font.

*****

This license is fine for Fedora.

Note You need to log in before you can comment on or make changes to this bug.