Bug 253782 - Boot fails with a kernel panic on my laptop
Boot fails with a kernel panic on my laptop
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
6
i686 Linux
urgent Severity urgent
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-21 17:14 EDT by D. Angelis
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-22 13:26:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lspci -nnvvvxxx (35.94 KB, text/plain)
2007-08-21 17:14 EDT, D. Angelis
no flags Details

  None (edit)
Description D. Angelis 2007-08-21 17:14:51 EDT
Description of problem:
New kernel fails on boot with a kernel panic.
This is the end result of the failure to detect the hard disk so kernel does not
have where to switchroot.
The boot device is a SATA HD on an Intel ICH7m controller in combined mode
(ata_piix 0000:00:1f.2: MAP [ P0 P2 IDE IDE ]) which normally gets handled by
libata(ata_piix) driver.


Version-Release number of selected component (if applicable):
2.6.22.2-42.fc6

How reproducible:
always

Steps to Reproduce:
1.just boot
2.
3.
  
Actual results:
kernel panic

Expected results:


Additional info:
Used to work fine with all previous FC6 kernels (including 2.6.22.1-32.fc6)
The only way to get the latest kernel to boot is to not use libata at all
by appending the kernel boot option "combined_mode=ide" which is not acceptable
since no DMA is used for my hard disk and therefore is very slow.
I can not provide a dmesg log since the panic happens too early.
Comment 1 D. Angelis 2007-08-21 17:14:51 EDT
Created attachment 162014 [details]
lspci -nnvvvxxx
Comment 2 D. Angelis 2007-08-22 13:26:48 EDT
Resolved:
Adding the next line in /etc/modprobe.conf and reinstalling the 2.6.22.2-42.fc6
kernel did the trick.
   options libata ignore_hpa=1

I guess some changes regarding HPA treatment originating from FC7 kernels lurked
in libata module.
I think a warning message in package-announce-list is in order here.

Note You need to log in before you can comment on or make changes to this bug.