Bug 253812 - Package Review: taipeifonts (split from fonts-chinese).
Summary: Package Review: taipeifonts (split from fonts-chinese).
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: Package Review   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Jens Petersen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: i18n, Reopened
Depends On:
Blocks: 253161
TreeView+ depends on / blocked
 
Reported: 2007-08-22 02:07 UTC by Caius Chance
Modified: 2010-03-11 13:32 UTC (History)
6 users (show)

Fixed In Version: taipeifonts-1.2-12.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-03-11 13:32:02 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
petersen: fedora-review+
kevin: fedora-cvs+


Attachments (Terms of Use)
taipeifonts.spec-1.patch (3.99 KB, patch)
2007-09-25 02:42 UTC, Jens Petersen
no flags Details | Diff
taipeifonts.spec-2.patch (1.26 KB, patch)
2007-09-28 02:18 UTC, Jens Petersen
no flags Details | Diff

Description Caius Chance 2007-08-22 02:07:32 UTC
+++ This bug was initially created as a clone of Bug #253161 +++

Description of problem:
fonts-chinese contains a number of different fonts, they should be
moved to packages that reflect the upstream project's name as far
as possible: eg to arphic-fonts and taipei-fonts.

-- Additional comment from cchance@redhat.com on 2007-08-19 07:58 EST --
Excuse me to ask, how could this proposal conserve the current convenience for
user to install formal chinese fonts when it is carried out?

-- Additional comment from petersen@redhat.com on 2007-08-19 20:42 EST --
fonts-chinese will require the new fonts packages.

Comment 2 Parag AN(पराग) 2007-08-22 05:36:23 UTC
Add license file in tarball.
Change License tag to one of compatible licenses allowed.
add postun section
Change buildroot
why Obsolete needed?
Is taipeifonts package present in fedora currently?

Comment 4 Jens Petersen 2007-08-29 01:00:13 UTC
It seems taipei-1.2.tar.gz seems to originate from the CLE
(Chinese Linux Extension) to Slackware from bitmaps taken from XFree86 perhaps.

Anyway I managed to track down a potential new upstream since taipei16
and taipei24 are included in GNU's intlfonts distribution.

 ftp://ftp.gnu.org/gnu/intlfonts/

The current version is 1.2.1.

http://directory.fsf.org/localization/intlfonts.html
lists the distribution as GPLv2+, verified by the FSF in 2001.
There is no COPYING or license file included in the tarball(s) though.
It would be good to ask Handa-san for clarification about that perhaps.


Comment 5 Jens Petersen 2007-08-29 01:24:57 UTC
So probably the Chinese.tar.gz in
ftp://ftp.gnu.org/gnu/intlfonts/intlfonts-1.2.1-split/
is a good candidate to replace taipeifonts.

Comment 6 Jens Petersen 2007-08-29 01:39:51 UTC
Oh and I just found:

http://ftp2.tnc.edu.tw/pub3/CLE/CLE/devel/wjwu/slackware/slackware-9.1/source/taipeifonts-1.2/re-build.readme

which claims the taipei fonts are Public Domain.

The taipei fonts are available here:
ftp://cle.linux.org.tw/pub2/fonts/bitmap/taipeifont

Comment 7 Parag AN(पराग) 2007-09-07 08:31:16 UTC
I think Jens can be good Reviewer for this package. 
Removing myself from review.

Comment 8 Warren Togami 2007-09-19 23:01:25 UTC
bump: reminding Jens =)

Comment 9 Jens Petersen 2007-09-20 03:33:14 UTC
Thanks - Caius should be back next week from holiday.

Comment 10 Jens Petersen 2007-09-25 02:36:19 UTC
I suggest let's rename it to taipeifonts if that is the upstream name.

 taipeifonts.src: W: no-url-tag

Is there URL for this?

 taipeifonts.noarch: W: no-documentation
 taipeifonts.noarch: W: no-url-tag

Any documentation files available?

intlfonts-1.2.1/Korean.X/README reads:

Koean Hangle&Hanja (KSC5601):
	hanglg16.bdf	from X.V11R5/mit/bdf/fonts/misc
	hanglm16.bdf	...
	hanglm24.bdf	...


Comment 11 Jens Petersen 2007-09-25 02:42:50 UTC
Created attachment 204781 [details]
taipeifonts.spec-1.patch

cleanup patch

Comment 13 Jens Petersen 2007-09-25 06:47:47 UTC
How about a url for the source?



Comment 14 Jens Petersen 2007-09-25 06:51:46 UTC
(BTW I can't reach ftp://cle.linux.org.tw/pub2/fonts/bitmap/taipeifont currently.)

Comment 17 Jens Petersen 2007-09-25 07:16:54 UTC
Review follows:

Good:
+ rpmlint clean
+ name follows upstream name (from CLE project)
+ meets packaging guidelines
+ fonts are public domain (no license file is included)
+ spec file is clear
+ dir and file ownership is good
+ macros used

Needs attention:
- no source url
- noarch package builds
- buildreqs listed

Dunno if it is not a good idea to include say
http://ftp2.tnc.edu.tw/pub3/CLE/CLE/devel/wjwu/slackware/slackware-9.1/source/taipeifonts-1.2/re-build.readme


Comment 18 Jens Petersen 2007-09-25 08:19:03 UTC
correction "- noarch package builds" should have been in the "Good" section.

Comment 20 Jens Petersen 2007-09-26 08:27:59 UTC
ugh, sorry, "buildreqs listed" should also have been under Good.

Comment 21 Jens Petersen 2007-09-26 08:48:14 UTC
How about
http://ftp2.tnc.edu.tw/pub3/CLE/CLE/devel/wjwu/slackware/slackware-9.1/source/taipeifonts-1.2/%{name}-%{version}.tar.gz
for the source url?

Do you have a better one?

Also I just noticed the "Buildroot" should updated to the current recommendations:
http://fedoraproject.org/wiki/Packaging/Guidelines#head-b4fdd45fa76cbf54c885ef0836361319ab962473


Comment 23 Jens Petersen 2007-09-28 02:16:01 UTC
URL field is for the project webpage not the source.
So we want one url for URL and one for SOURCE.

How about:

URL:  http://cle.linux.org.tw/

Though they don't mention taipeifonts on the website directly anymore
I think it is respectful to acknowledge the work of CLE here.

Source0:
http://ftp2.tnc.edu.tw/pub3/CLE/CLE/devel/wjwu/slackware/slackware-9.1/source/taipeifonts-1.2/taipeifonts-1.2.tar.gz

using %{name}-%{version}.tar.gz is better since it shows that the name and
version follows upstream.

Add

Source2:
http://ftp2.tnc.edu.tw/pub3/CLE/CLE/devel/wjwu/slackware/slackware-9.1/source/taipeifonts-1.2/re-build.readme


Comment 24 Jens Petersen 2007-09-28 02:18:20 UTC
Created attachment 209341 [details]
taipeifonts.spec-2.patch

Here is a patch with a better base url.

Comment 27 Jens Petersen 2007-09-28 04:58:04 UTC
taipeifonts.noarch: W: incoherent-version-in-changelog 1.2-4 1.2-3.fc7

Please bump the release.

Also please preserve the timestamp of the readme file in %prep with "cp -p".

Comment 29 Jens Petersen 2007-09-28 07:19:05 UTC
For the record here is the md5sum of the source tarball:

9e4acdd5a218dea6aaa28bc80d472aad  taipeifonts-1.2.tar.gz

which coincides with the one from CLE.

Thanks for the review.

This package is APPROVED.

Comment 30 Caius Chance 2007-10-01 00:39:10 UTC
New Package CVS Request
=======================
Package Name: taipeifonts
Short Description: Chinese bitmap fonts.
Owners: cchance
Branches: devel
InitialCC: 
Cvsextras Commits: yes

Comment 31 Jens Petersen 2007-10-01 04:21:36 UTC
cvsadmin done

Comment 32 Caius Chance 2007-10-01 07:05:12 UTC
Built into rawhide.

Comment 33 Caius Chance 2010-03-04 05:11:10 UTC
New Package CVS Request
=======================
Package Name: taipeifonts
Short Description: Chinese bitmap fonts
Owners: kaio
Branches: F-13
InitialCC: i18n-team

Comment 34 Kevin Fenzi 2010-03-06 05:09:31 UTC
F13 branch added.

Comment 35 Fedora Update System 2010-03-08 02:53:20 UTC
taipeifonts-1.2-12.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/taipeifonts-1.2-12.fc13

Comment 36 Fedora Update System 2010-03-09 03:25:56 UTC
taipeifonts-1.2-12.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update taipeifonts'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/taipeifonts-1.2-12.fc13

Comment 37 Fedora Update System 2010-03-11 13:31:56 UTC
taipeifonts-1.2-12.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.