Bug 253827 - Spec patch to fix tomcat build on alpha
Spec patch to fix tomcat build on alpha
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: tomcat5 (Show other bugs)
rawhide
alpha Linux
low Severity low
: ---
: ---
Assigned To: Devrim GUNDUZ
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-22 04:39 EDT by Oliver Falk
Modified: 2008-02-13 00:13 EST (History)
0 users

See Also:
Fixed In Version: 5.5.26-1jpp.2.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-12 23:54:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Oliver Falk 2007-08-22 04:39:24 EDT
Seems to be a similar problem as on ppc64 and s390x, so the fix is the same.
Just add alpha to all places where ppc64 is. :-)

Index: tomcat5.spec
===================================================================
RCS file: /cvs/pkgs/devel/tomcat5/tomcat5.spec,v
retrieving revision 1.101
diff -u -p -r1.101 tomcat5.spec
--- tomcat5.spec        9 Aug 2007 20:40:20 -0000       1.101
+++ tomcat5.spec        22 Aug 2007 08:11:44 -0000
@@ -98,7 +98,7 @@ Patch12: %{name}-%{majversion}-util-buil
 Patch13: %{name}-%{version}-http11-build.patch
 Patch14: %{name}-%{majversion}-jk-build.patch
 Patch16: %{name}-%{majversion}-jspc-classpath.patch
-#FIXME Disable JSP pre-compilation on ppc64 and x390x
+#FIXME Disable JSP pre-compilation on ppc64,  s390x and alpha
 Patch18: %{name}-%{majversion}-skip-jsp-precompile.patch
 # XXX:
 # Seems to be only needed when building with ECJ for java 1.5 since
@@ -444,7 +444,7 @@ cd %{packdname}
 %patch13 -b .p13
 %patch14 -b .p14
 %patch16 -b .p16
-%ifarch ppc64 s390x
+%ifarch ppc64 s390x alpha
 %patch18 -b .p18
 %endif
 %patch19 -b .p19
@@ -1217,7 +1217,7 @@ fi
 %dir %{appdir}/webdav
 %{appdir}/webdav/*
 %if %{gcj_support}
-%ifnarch ppc64 s390x
+%ifnarch ppc64 s390x alpha
 %attr(-,root,root) %{_libdir}/gcj/%{name}/catalina-root*
 %endif
 %endif
Comment 1 Oliver Falk 2007-08-22 04:41:57 EDT
And this hunk as well:
@@ -591,7 +591,7 @@ unzip -qq ../apache-tomcat-5.5.23-src/bu
   -x META-INF/MANIFEST.MF org/apache/jasper/compiler/Localizer.class
 unzip -qq %{_javadir}/jdtcore.jar -x META-INF/MANIFEST.MF
 cp %{SOURCE6} META-INF/MANIFEST.MF
-rm plugin.properties plugin.xml about.html jdtCompilerAdapter.jar
META-INF/eclipse.inf 
+rm -f plugin.properties plugin.xml about.html jdtCompilerAdapter.jar
META-INF/eclipse.inf 
 zip -qq -r ../org.apache.jasper_5.5.17.v200706111724.jar .
 popd
 %endif



For some reason META-INF/eclipse.inf doesn't exist, when I build it here and
build fails at that point, because it cannot remove the file :-(
Comment 2 Oliver Falk 2007-11-27 10:10:42 EST
ping!
Comment 3 Devrim GUNDUZ 2008-01-05 08:31:42 EST
Thanks. These fixes will appear in next Tomcat5 build.
Comment 4 Fedora Update System 2008-01-06 20:23:40 EST
tomcat5-5.5.25-2jpp.1.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update tomcat5'
Comment 5 Fedora Update System 2008-01-06 20:28:26 EST
tomcat5-5.5.25-2jpp.1.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update tomcat5'
Comment 6 Fedora Update System 2008-02-08 19:31:44 EST
tomcat5-5.5.26-1jpp.1.fc7 has been submitted as an update for Fedora 7
Comment 7 Fedora Update System 2008-02-08 19:34:50 EST
tomcat5-5.5.26-1jpp.1.fc8 has been submitted as an update for Fedora 8
Comment 8 Fedora Update System 2008-02-12 15:31:46 EST
tomcat5-5.5.26-1jpp.2.fc8 has been submitted as an update for Fedora 8
Comment 9 Fedora Update System 2008-02-12 15:34:06 EST
tomcat5-5.5.26-1jpp.2.fc7 has been submitted as an update for Fedora 7
Comment 10 Fedora Update System 2008-02-12 23:54:18 EST
tomcat5-5.5.26-1jpp.2.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Fedora Update System 2008-02-13 00:13:50 EST
tomcat5-5.5.26-1jpp.2.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.