Bug 253881 - fedora-logos requires X11 to be installed
fedora-logos requires X11 to be installed
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: fedora-logos (Show other bugs)
7
All Linux
medium Severity low
: ---
: ---
Assigned To: David Zeuthen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-22 12:18 EDT by Fabian Deutsch
Modified: 2013-03-05 22:51 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-13 16:37:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Fabian Deutsch 2007-08-22 12:18:16 EDT
Description of problem:
fedora-logos requires gtk-engines and dependants to be installed. This quite
"bad" because grub also depends on fedora-logos. Normally this si no problem.
But disturbed me, when updateing a FC6 machine to F7 without X11

Version-Release number of selected component (if applicable):


How reproducible:
Update some FC6 machine to F7 without gtk-enngines etc.

Steps to Reproduce:
1. rpm -Uvh .../fedora-release... .../redora-release-notes...
2. yum update
3. Look at the dependency list
  
Actual results:
yum tries to install gtk2 and all related stuff, all in all: X1

Expected results:
If i update a machine without X11 I would like the update also to exclude X11

Additional info:
It all depends on the spals.xpm.gz grub is using ...
Comment 1 Bill Nottingham 2007-09-13 16:37:04 EDT
This is fixed in 6.0.98-4 or later, such as the packages in Fedora 8 test2.

Note You need to log in before you can comment on or make changes to this bug.