Bug 253887 - boot hangs for a few minutes probing non-existant floppy drive
boot hangs for a few minutes probing non-existant floppy drive
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: mkinitrd (Show other bugs)
8
All Linux
medium Severity high
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
bzcl34nup
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-22 13:30 EDT by Orion Poplawski
Modified: 2008-07-14 16:06 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-14 16:06:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Orion Poplawski 2007-08-22 13:30:00 EDT
Description of problem:

This used to be limited to during kernel install, but with current development
kernels the boot process is slowed by about 4 minutes while it tries to access
the floppy drive.  This is unacceptable.  Messages are:

Floppy drive(s): fd0 is 1.44M
FDC 0 is a post-1991 82077
Loading iSCSI transport class v2.0-724.
end_request: I/O error, dev fd0, sector 0
end_request: I/O error, dev fd0, sector 0
Buffer I/O error on device fd0, logical block 0
end_request: I/O error, dev fd0, sector 0
Buffer I/O error on device fd0, logical block 0
end_request: I/O error, dev fd0, sector 0
end_request: I/O error, dev fd0, sector 0
Buffer I/O error on device fd0, logical block 0
end_request: I/O error, dev fd0, sector 0
Buffer I/O error on device fd0, logical block 0
end_request: I/O error, dev fd0, sector 0
end_request: I/O error, dev fd0, sector 0
Buffer I/O error on device fd0, logical block 0
end_request: I/O error, dev fd0, sector 0
Buffer I/O error on device fd0, logical block 0

This did not happen with F7 kernels.  Instead I simply got:

Floppy drive(s): fd0 is 1.44M
FDC 0 is a post-1991 82077

Hardware is a Dell Inspiron 4150 with the removable floppy device out of the
machine.

Version-Release number of selected component (if applicable):
2.6.23-0.115.rc3.git1.fc8
Comment 1 Orion Poplawski 2007-09-12 15:49:17 EDT
If it helps, last message printed without "quiet" in the command line is:

Mounting root filesystem

Boots don't seem to hanging quite so long with 2.6.23-0.174.rc6.fc8, don't get
as many messages:

Loading iSCSI transport class v2.0-724.
end_request: I/O error, dev fd0, sector 0
end_request: I/O error, dev fd0, sector 0
Buffer I/O error on device fd0, logical block 0
end_request: I/O error, dev fd0, sector 0
Buffer I/O error on device fd0, logical block 0

but each "end_request" takes about 30 seconds I think and it is still a pain.
Comment 2 Chuck Ebbert 2007-09-12 17:26:16 EDT
Is there some other device in the bay where the floppy normally goes or is it
completely empty?
Comment 3 Orion Poplawski 2007-09-12 18:35:56 EDT
Currently the CD-RW drive is in the slot.
Comment 4 Chuck Ebbert 2007-09-13 13:22:13 EDT
(In reply to comment #3)
> Currently the CD-RW drive is in the slot.

Try it with the bay completely empty.
Comment 5 Orion Poplawski 2007-09-13 15:48:06 EDT
With the bay completely empty I get no noticeable boot delays and only a singe:

 end_request: I/O error, dev fd0, sector 0

line.
Comment 6 Chuck Ebbert 2007-09-13 16:06:33 EDT
(In reply to comment #5)
> With the bay completely empty I get no noticeable boot delays and only a singe:
> 
>  end_request: I/O error, dev fd0, sector 0
> 
> line.
> 

Okay, what happens if you disable the "bay" driver and boot with the CD drive
present? (Edit /etc/modprobe.d/blacklist to disable the driver.)
Comment 7 Orion Poplawski 2007-10-04 17:29:00 EDT
This is really driving me crazy and has gotten worse again.

After some exploring I think this my have to do with populating
/dev/disk/by-label to that mount can fine the root partition (LABEL=/1 in this
case).  I've been running across a lot of code in various places that insists on
probing the floppy device for labels, often before searching hard disks (because
/sys/block/fd0 comes before /sys/block/sda).  I imagine that is this case
populating /dev/disk/by-label may require probing all devices, but perhaps we
could "background" probing /dev/fd0.  Is any one going to rely on disklabels on
floppies?
Comment 8 Orion Poplawski 2007-10-17 11:48:54 EDT
Culprit is mkinitrd's nash and block device scanning searching for labels.  This
really needs to get tweaked so that we probe hard drives first, or maybe
completely exclude floppies from the by label/uuid search.
Comment 9 Bug Zapper 2008-04-04 09:39:42 EDT
Based on the date this bug was created, it appears to have been reported
during the development of Fedora 8. In order to refocus our efforts as
a project we are changing the version of this bug to '8'.

If this bug still exists in rawhide, please change the version back to
rawhide.
(If you're unable to change the bug's version, add a comment to the bug
and someone will change it for you.)

Thanks for your help and we apologize for the interruption.

The process we're following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.

Note You need to log in before you can comment on or make changes to this bug.