This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 253888 - Anaconda Kickstart doesn't see zFCP devices (sda)
Anaconda Kickstart doesn't see zFCP devices (sda)
Status: CLOSED NEXTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: anaconda (Show other bugs)
5.0
All Linux
low Severity high
: ---
: ---
Assigned To: David Cantrell
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-22 13:31 EDT by Arlinton Bourne
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-23 13:46:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Kickstart zFCP (5.60 KB, application/octet-stream)
2007-08-23 13:35 EDT, Arlinton Bourne
no flags Details

  None (edit)
Description Arlinton Bourne 2007-08-22 13:31:07 EDT
Description of problem:
Within the kickstart file for a RHEL5 s390x install. 
Using the keyword zFCP and it's options sets up my FCP drives. They come up as
sda and sdb. Alas when trying to partition them using the part commands anaconda
whines and quits essentially complaining that at kickstart line X nonexistant
drive sda.
The kickstart line looks like:
part raid.30 --size=100 --grow --ondisk=sda
part raid.31 --size=100 --grow --ondisk=sdb

Also I'm passing proper FCP_x  arguments via zVM.

I've tried initiating the zFCP drive manually in my pre script.
It does the same stuff.

The installation works file w/o kickstart.


Version-Release number of selected component (if applicable):
RHEL 5 GOLD INSTALL

How reproducible:
100%
Comment 1 David Cantrell 2007-08-22 13:43:53 EDT
Is this happening with a 5.1 tree?  Nightly or beta.
Comment 2 Arlinton Bourne 2007-08-22 15:42:20 EDT
I haven't tried this with a 5.1 tree as yet. Should I?
Also I've found out that the: 

clearpart --all --initlabel 

seems not to work as well.
While DASDs are get formatted by dasdfmt the zFCP devices do not get
(re)initialized and still have information on them.

I deducted this by creating a md1 device out of the zFCP devices when i
installed RHEL and adding it to VolGroup00, extending the root lv (LogVol00),
expanding the ext3 fs then kicking off a fresh install (manually).

Next thing I'll attach is the kickstart file.

Comment 3 David Cantrell 2007-08-22 15:46:11 EDT
Yeah, please do testing with 5.1 trees now.  We're so near the release and so
much work has gone in to 5.1 now.
Comment 4 Arlinton Bourne 2007-08-23 13:35:24 EDT
Created attachment 171256 [details]
Kickstart zFCP

It works well on the 20070822.1 tree
Just fails badly on 5.0 Gold

Here is the kickstart file.

Note You need to log in before you can comment on or make changes to this bug.