Bug 25389 - tree prints color even if "COLOR none" in /etc/DIR_COLORS is set
tree prints color even if "COLOR none" in /etc/DIR_COLORS is set
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: tree (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-01-31 12:04 EST by Zing
Modified: 2009-05-29 15:41 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-10-05 06:40:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
use -n flag by default (1.32 KB, patch)
2001-01-31 21:21 EST, Zing
no flags Details | Diff
updated no-colour patch (1.56 KB, patch)
2009-05-29 15:41 EDT, Zing
no flags Details | Diff

  None (edit)
Description Zing 2001-01-31 12:04:57 EST
when "COLOR none" is set in /etc/DIR_COLORS, tree will still use colors.
The man page does say it will use colors if LS_COLORS is set so it sounds
like documented but non-standard behavior?
Comment 1 Pekka Savola 2001-01-31 15:18:18 EST
DIR_COLOURS stuff didn't really work in RHL7 out of the box IIRC; see: #16918

You could try updating to the latest fileutils from Rawhide.
Comment 2 Zing 2001-01-31 21:21:55 EST
Created attachment 8622 [details]
use -n flag by default
Comment 3 Zing 2001-01-31 21:24:36 EST
weelll, fileutils-4.0x-3(#16918) is in RH7.0 already.  I think tree should be
consistent with ls and not do color by default.  I attached a small patch which
does minimum damage... i think :)
Comment 4 Tim Waugh 2001-10-22 04:49:43 EDT
Fixed in tree-1.2-14.
Comment 5 Zing 2009-05-26 16:19:20 EDT
<sad panda face> :( </sad panda face>

Why was the no color patch dropped?

I'd be willing to get this fixed the "right" way, whichever way that is if you let me know how to proceed.
Comment 6 Zing 2009-05-29 15:41:59 EDT
Created attachment 345950 [details]
updated no-colour patch

I updated the patch to apply without fuzz in the case that was the reason for dropping it.

I'm willing to help comaintain if that would help.

Note You need to log in before you can comment on or make changes to this bug.