Bug 253898 - check_linux_raid.pl uses wrong lib path on x86_64 systems
check_linux_raid.pl uses wrong lib path on x86_64 systems
Status: CLOSED NEXTRELEASE
Product: Fedora EPEL
Classification: Fedora
Component: nagios-plugins (Show other bugs)
el5
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Mike McGrath
Fedora Extras Quality Assurance
:
: 442876 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-22 15:22 EDT by Kevin O'Brien
Modified: 2008-10-06 09:10 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-28 23:10:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kevin O'Brien 2007-08-22 15:22:41 EDT
The check_linux_raid.pl plugin from
nagios-plugins-linux_raid-1.4.6-3.el5.x86_64.rpm uses the wrong lib path on
x86_64 systems.  It has:

use lib '/usr/lib/nagios/plugins';

it should be:

use lib '/usr/lib64/nagios/plugins';
Comment 1 Mike McGrath 2008-09-28 22:54:37 EDT
I might be doing something wron here (in fact I know I am since I haven't touched this ticket in over a year but...)

Are you actually seeing issues with that lib path?
Comment 2 Mike McGrath 2008-09-28 22:55:59 EDT
nm, I see what I was doing wrong there.  I'm not quite sure what the fix for this is going to be yet.  It seems contrib/subst isn't doing what it should be.  Looking further.
Comment 3 Mike McGrath 2008-09-28 22:57:35 EDT
*** Bug 442876 has been marked as a duplicate of this bug. ***
Comment 4 Mike McGrath 2008-09-28 23:10:53 EDT
Ok, I got this figured out.  I'll be building a new version (upstream released a new version as well)  sorry this took so long.
Comment 5 Fedora Update System 2008-10-02 10:04:32 EDT
nagios-plugins-1.4.13-4.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/nagios-plugins-1.4.13-4.fc9
Comment 6 Fedora Update System 2008-10-02 10:05:29 EDT
nagios-plugins-1.4.13-4.fc8 has been submitted as an update for Fedora 8.
http://admin.fedoraproject.org/updates/nagios-plugins-1.4.13-4.fc8
Comment 7 Fedora Update System 2008-10-03 18:31:15 EDT
nagios-plugins-1.4.13-4.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Fedora Update System 2008-10-03 18:35:05 EDT
nagios-plugins-1.4.13-4.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Rénald Casagraude 2008-10-06 08:25:35 EDT
The trailling ';' is missing on the use lib line :(
Comment 10 Mike McGrath 2008-10-06 09:10:36 EDT
Thats awesome.

Note You need to log in before you can comment on or make changes to this bug.