Bug 253935 - can no longer hex edit certain files.
can no longer hex edit certain files.
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: mc (Show other bugs)
7
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Jindrich Novy
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-22 20:24 EDT by Dave Jones
Modified: 2015-01-04 17:29 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-05 13:00:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dave Jones 2007-08-22 20:24:13 EDT
try this..

gcc helloworld.c

mc

move over the a.out

f3 (View)
f4 (switch to hex)
f2 (edit)

nothing happens. Because f2 is an empty menu option. (It doesn't even have an
"edit" label).  Doing the same procedure on another file allows hex editing.
Comment 1 Michael Schwendt 2008-04-05 10:37:41 EDT
Not a bug. Your F-Key-sequence ought to be:

F3 (View)
F8 (Raw)    <-- (!)
F4 (Hex)
F2 (Edit)
Comment 2 Jindrich Novy 2008-04-05 13:00:23 EDT
Indeed. mc allows switching between Parse/Raw mode to allow editing.
Comment 3 Dave Jones 2008-04-05 14:10:25 EDT
weird.  f3-f4-f2 works fine for other files, just not executables.
Comment 4 Michael Schwendt 2008-04-05 19:08:39 EDT
Enter MC menu "Command > Edit extension file", then look for

  type/^ELF

You can disable the default View= action there if it annoys you.
There are similar actions defined for many other file types.

Note You need to log in before you can comment on or make changes to this bug.