Bug 253962 - missing requirement for %postun scriptlet
missing requirement for %postun scriptlet
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: docbook-style-xsl (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Ondrej Vasik
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-23 05:16 EDT by Rudolf Kastl
Modified: 2007-12-10 15:49 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-24 06:54:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rudolf Kastl 2007-08-23 05:16:59 EDT
Description of problem:
%postun executes /usr/bin/xmlcatalog while there is no explicit postun
requirement for its providing package, which results in uninstall post scriptlet
errors on a minimal install that got the package yummed.

Version-Release number of selected component (if applicable):
docbook-style-xsl-1.73.0-2.fc8
Comment 1 Ondrej Vasik 2007-09-07 08:27:49 EDT
PreReq: libxml2 >= 2.4.8 added to spec file...
First corrected version is docbook-style-xsl-1.73.2-2.fc8.
Closing RAWHIDE.
Comment 2 Rudolf Kastl 2007-09-27 10:25:52 EDT
this issue is not fixed yet what is missing is a Requires(postun)
Comment 3 Ondrej Vasik 2007-10-23 11:35:42 EDT
Missing is Requires(post) and Requires(postun), because /usr/bin/xmlcatalog is
used in both sections. Will be done during my rpmlint cleanup of the package -
there is a lot of other issues.
Comment 4 Ondrej Vasik 2007-10-24 06:54:44 EDT
RPMlint check done, built as docbook-style-xsl-1.73.2-3.fc9 with hopefully
correct requirements. Closing RAWHIDE again...
Comment 5 Fedora Update System 2007-12-10 15:49:04 EST
docbook-style-xsl-1.73.2-2.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update docbook-style-xsl'

Note You need to log in before you can comment on or make changes to this bug.