This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 25397 - up2date fails to update specifically named files.
up2date fails to update specifically named files.
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: up2date (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Preston Brown
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-01-31 15:24 EST by Jonathan J. Miner
Modified: 2015-01-07 18:42 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-19 20:35:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jonathan J. Miner 2001-01-31 15:24:10 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0)


When noReplaceConfig=1 is in /etc/sysconfig/rhn/up2date, up2date will not 
update files where the config has changed, even if it is explicitly told 
to do so.  (i.e. up2date pkgname)

Reproducible: Always
Steps to Reproduce:
1. Install RH7
2. Modify /etc/ld.so.conf (add a non-standard directory, for whatever 
reason)
3. Run "up2date -l", this will list all updates, along with listing glibc 
as a package that will be skipped because its configuration has changed.
4. Run "up2date glibc" to update glibc, regardless the status of it's 
configuration files.

Actual Results:  Does not update, listing that the package was skipped.

Expected Results:  Update the package, since it was explicitly requested.
Comment 1 Adrian Likins 2001-02-07 23:54:37 EST
This should be fixed in the next release of up2date.
Comment 2 Preston Brown 2001-02-08 22:39:46 EST
fixed is stretching it; the old behaviour was the original design.  However, we
agree that what you tried to do is more intuitive, so we have changed it.

This will be the default behaviour in the next release.
Comment 3 Cristian Gafton 2001-02-19 20:35:32 EST
Assigned QA to jturner
Comment 4 Jay Turner 2001-03-07 16:10:39 EST
We have implemented a '--force' option which is used to override all
configuration options and just do what the user says (download, install,
whatever)  So, that being the case, we are going to leave this feature as designed.

Note You need to log in before you can comment on or make changes to this bug.