Bug 253991 - Traceback from resolveDeps as part of mash
Traceback from resolveDeps as part of mash
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-23 10:02 EDT by Jesse Keating
Modified: 2014-01-21 17:59 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-13 15:10:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Change the default value of version to (None, None, None) (6.88 KB, patch)
2007-08-23 10:35 EDT, Florian Festi
no flags Details | Diff

  None (edit)
Description Jesse Keating 2007-08-23 10:02:52 EDT
Mash makes a call to resolveDeps as part of the multilib discovery process.  As
of last night we started getting a traceback:

Traceback (most recent call last):
  File "/usr/bin/mash", line 69, in <module>
    main()
  File "/usr/bin/mash", line 57, in main
    rc = themash.doMultilib()
  File "/usr/lib/python2.5/site-packages/mash/__init__.py", line 411, in doMultilib
    pid = self.doDepSolveAndMultilib(arch, cachedir, fork = self.config.fork)
  File "/usr/lib/python2.5/site-packages/mash/__init__.py", line 378, in
doDepSolveAndMultilib
    (rc, errors) = yumbase.resolveDeps()
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 709, in resolveDeps
    for po, dep in self._checkFileRequires():
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 910, in
_checkFileRequires
    if not self.tsInfo.getOldProvides(filename) and not
self.tsInfo.getNewProvides(filename):
  File "/usr/lib/python2.5/site-packages/yum/transactioninfo.py", line 386, in
getNewProvides
    result.update(self.localSack.getProvides(name, flag, version))
  File "/usr/lib/python2.5/site-packages/yum/packageSack.py", line 451, in
getProvides
    hits = po.matchingPrcos('provides', (name, flags, version))
  File "/usr/lib/python2.5/site-packages/yum/packages.py", line 272, in
matchingPrcos
    (reqn, reqf, (reqe, reqv, reqr)) = reqtuple
TypeError: 'NoneType' object is not iterable


From IRC:

<ffesti> skvidal, f13: looks like there's a problem with defaulting version to None
<ffesti> we can either change the default to (None, None, None) or make
matchingPrcos() and cousins a bit more tolerant

Fixing this is somewhat urgent so that we can have rawhide flowing again prior
to the Feature Freeze.
Comment 1 Florian Festi 2007-08-23 10:35:03 EDT
Created attachment 168809 [details]
Change the default value of version to (None, None, None)

This patch should fix it. Can you please verify it really does? Thanks!
Comment 2 Jeremy Katz 2007-09-13 15:10:26 EDT
This got fixed up

Note You need to log in before you can comment on or make changes to this bug.