Bug 254023 - gimp errors out immediately in clone tool
gimp errors out immediately in clone tool
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gimp (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Nils Philippsen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-23 13:36 EDT by Michal Jaegermann
Modified: 2008-08-02 19:40 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-24 11:01:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2007-08-23 13:36:39 EDT
Description of problem:

Trying the first thing in gimp after loading a picture, and this
happened to be "clone tool", I immediately got:

Gdk-ERROR **: The program 'gimp' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadWindow (invalid Window parameter)'.
  (Details: serial 65222 error_code 3 request_code 39 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)
aborting...
gimp: terminated: Aborted

(script-fu:3087): LibGimpBase-WARNING **: script-fu: gimp_wire_read(): error

The above was already with '--sync' added to an invocation.

Apparently an area to clone was aquired ok but any attempt to apply
a cloned brush results in the above and an immediate termination
of the program.

This was on x86_64 and I do not have means to check another architectures.
Radeon video card.

Version-Release number of selected component (if applicable):
gimp-2.4.0-0.rc1.1.fc8
gtk2-2.11.6-6.fc8
libX11-1.1.2-2.fc8
xorg-x11-server-Xorg-1.3.0.0-20.fc8
xorg-x11-drv-ati-6.6.193-3.fc8

How reproducible:
always
Comment 1 Michal Jaegermann 2007-08-23 14:16:22 EDT
Apparently I was "lucky" trying a clone tool first.  Scaling down
a sample image worked for me.  OTOH trying to "clone" something on
a scaled down picture, or painting after picking up a colour,
ended up with the same kind of error.  I was able to click four
or five times, though,  with a "cloned" brush before gimp aborted
again but this could be a coincidence.  An attempt to paint bombed
out right away.
Comment 2 Nils Philippsen 2007-08-31 08:51:23 EDT
Works for me with current svn (also on x86_64) on F7. A new RC is due soon which
should hopefully fix this.
Comment 3 Nils Philippsen 2007-09-05 03:19:37 EDT
Should be fixed in gimp-2.4.0-0.rc2.1.fc8, please check.
Comment 4 Michal Jaegermann 2007-09-24 11:01:12 EDT
Yes, it looks that it works now; at least with gimp-2.4.0-0.rc2.2.fc8.
Sorry for a delay; I was away.

Note You need to log in before you can comment on or make changes to this bug.