Bug 254026 - bcm4318 not working on my powerbook
bcm4318 not working on my powerbook
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
7
All Linux
medium Severity medium
: ---
: ---
Assigned To: John W. Linville
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-23 14:03 EDT by Josef Bacik
Modified: 2007-11-30 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-30 17:59:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
dmesg (82.00 KB, text/plain)
2007-08-23 14:03 EDT, Josef Bacik
no flags Details

  None (edit)
Description Josef Bacik 2007-08-23 14:03:38 EDT
Description of problem:
I have the following card

0001:10:11.0 0280: 14e4:4318 (rev 02)

0001:10:11.0 Network controller: Broadcom Corporation BCM4318 [AirForce One 
54g] 802.11g Wireless LAN Controller (rev 02)

It will respond to

iwlist wlan0 scanning

and shows everything properly, but NetworkManager and manually configuring the 
device with iwconfig does not work properly, it will not associate with my AP 
(note that I've only tried with WEP AP's at this point, my box just stopped 
crashing alot so I will try with a non WEP AP tonight).  When NetworkManager 
starts I get a traceback and I'm getting an error and a traceback every couple 
of minutes.  I will provide my dmesg so you can see that.

Version-Release number of selected component (if applicable):

[root@localhost ~]# uname -a
Linux localhost.localdomain 2.6.23-0.129.rc3.git4.fc8 #1 Wed Aug 22 01:26:42 
EDT 2007 ppc ppc ppc GNU/Linux

The firmware I got was from a website (off of a gentoo forum somewhere)

broadcom-wl-4.80.53.0

the WHERE_FROM file shows this

[root@localhost broadcom-wl-4.80.53.0]# cat WHERE_FROM
From the Linksys WRT350N v1.03.2 GPL release
Comment 1 Josef Bacik 2007-08-23 14:03:39 EDT
Created attachment 172368 [details]
dmesg
Comment 2 Josef Bacik 2007-08-23 17:59:13 EDT
alright turns out I can connect to an open wireless network, and I want to 
blame knetworkmanager for not prompting me for my WEP, so as far as my 
wireless working I think I'm good, however those tracebacks bother me a bit so 
I'm still going to leave the bz open.
Comment 3 John W. Linville 2007-08-30 17:59:37 EDT
The "Invalid LO control pair" is debugging garbage.  Be sure to try the latest 
rawhide or 77.fc7 -- I think that has been recently changed/removed.  Anyway, 
they are harmless, so I'm going to go ahead and close this since you seem to 
be working.

Note You need to log in before you can comment on or make changes to this bug.