Bug 254045 - desktop-effects cli tool needed to disable compiz
desktop-effects cli tool needed to disable compiz
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: compiz (Show other bugs)
7
All Linux
low Severity low
: ---
: ---
Assigned To: Kristian Høgsberg
Fedora Extras Quality Assurance
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-23 15:38 EDT by Martin Jürgens
Modified: 2007-12-05 19:29 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-05 19:29:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Jürgens 2007-08-23 15:38:35 EDT
Description of problem:
A desktop-effects cli tool is needed to disable compiz. 

An use case is that the user is unable to disable compiz via the desktop-effects
gui because this freezes the system (i am going to report a bug on this). So the
user may want to switch to a console (CTL ALT F2) and run something like
desktop-effects --disable-compiz.

This way, he does not have to tinker around with config files that
desktop-effects modified.
Comment 1 Matěj Cepl 2007-12-05 19:03:48 EST
This looks to me like too complicated solution. Wouldn't just starting new Gnome
session (select different session in the GDM menu) be enough?
Comment 2 Matěj Cepl 2007-12-05 19:29:06 EST
Or even better. Log out of X session and then in console run

gconftool-2 –type string –set /apps/gnome-session/rh/window_manager "metacity"

I don't think creating a special application just in case compiz is broken is
good idea. This is NOTABUG. If you see any reasons why there is real bug (aside
from the compiz one, which is not the issue here), please reopen with additional
information.

Note You need to log in before you can comment on or make changes to this bug.