Bug 25408 - Default firewall configuration blocks name resolution
Summary: Default firewall configuration blocks name resolution
Status: CLOSED DUPLICATE of bug 25951
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-01-31 21:18 UTC by Dan Taylor
Modified: 2014-03-17 02:18 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-01 18:39:09 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Dan Taylor 2001-01-31 21:18:40 UTC
During installation the default firewall option (high) produces ipchains 
rules that prevent the local machine from doing proper name resolution.
The /etc/sysconfig/ipchains file looks like this:

:input ACCEPT
:forward ACCEPT
:output ACCEPT
-A input -s 0/0 -d 0/0 -i lo -j ACCEPT
-A input -s 0/0 -d 0/0 -p tcp -y -j DENY
-A input -s 0/0 -d 0/0 -p udp -j DENY

The last line is blocking the return packets from the name server.   
Modifying the last line to this resolves the issue:

-A input -s 0/0 ! 53 -d 0/0 -p udp -j DENY

Comment 1 Bill Nottingham 2001-02-01 16:43:57 UTC
Did you not set up a nameserver during the install?

Comment 2 Daniel Roesen 2001-02-01 18:05:20 UTC
Fixing version to "beta3"

Comment 3 Dan Taylor 2001-02-01 18:10:00 UTC
Yes a nameserver was already setup. here is my /etc/resolv.conf  

search localdomain
nameserver 143.166.71.254
nameserver 143.166.99.254

The ipchains rule prevents the client from being able to resolve any names 
though.

Comment 4 Bill Nottingham 2001-02-01 18:23:17 UTC
Where did you configure the networking setup?

Comment 5 Dan Taylor 2001-02-01 18:26:09 UTC
It was setup during the install to use dhcp.

Comment 6 Bill Nottingham 2001-02-01 18:32:29 UTC
Was this a local install or a network install?

Comment 7 Dan Taylor 2001-02-01 18:39:05 UTC
Local

Comment 8 Bill Nottingham 2001-02-05 16:00:28 UTC

*** This bug has been marked as a duplicate of 25951 ***


Note You need to log in before you can comment on or make changes to this bug.