Bug 254096 - system-install-packages doesn't see a difference between i386 and x86_64 packages
Summary: system-install-packages doesn't see a difference between i386 and x86_64 pack...
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: pirut   
(Show other bugs)
Version: 6
Hardware: x86_64
OS: Linux
urgent
urgent
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-08-24 03:33 UTC by -M
Modified: 2007-11-30 22:12 UTC (History)
1 user (show)

Fixed In Version: f7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-24 13:53:34 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description -M 2007-08-24 03:33:13 UTC
Since I can't find system-install-packages I had to file this under anaconda,
which makes some sense because anaconda but both i386 and x86_64 packages on the
machine to start with.

The problem is that if you remove either the i386 or x86_64 version of a package
and try to reinstall it via system-package-installer it tells you that the
package is already installed and it even says it's the other package you are
trying to install down to the arch, for example:

Trying to install the X86_64 package for ImageMagick with the i386 version
already installed reports:

ImageMagick-6.2.8.0-3.fc6.x86_64.rpm is already installed

This works in reverse too when trying to install the i386 version with the
X86_64 version already installed.

Comment 1 Jeremy Katz 2007-08-24 13:53:34 UTC
This is fixed up in Fedora 7

Comment 2 -M 2007-08-24 19:47:45 UTC
OK, I'll grab that then, thanks.


Note You need to log in before you can comment on or make changes to this bug.