Bug 25411 - tar can't backup into a remote device
Summary: tar can't backup into a remote device
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: dump (Show other bugs)
(Show other bugs)
Version: 6.2
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-01-31 21:22 UTC by Roger Pena-Escobio
Modified: 2007-04-18 16:31 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-07 19:17:07 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Roger Pena-Escobio 2001-01-31 21:22:37 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 4.01; Windows NT)


when i try to backup to a remote host using tar (tar -f host:/backup) it 
report "/etc/rmt not such file or directory" and abort. 

Reproducible: Always
Steps to Reproduce:
1.as root create an .rhost file in /root/ with this line "<hostname> root" 
where <hostname> is the name of your host. 
2.open your rsh port: edit the inetd.conf file and uncomment the line rsh 
line, execute killall -HUP inetd .
3.check that you have installed the last rmt version (rmt-0.4b19-5.6x)
	

Actual Results:  
bash: /etc/rmt: No such file or directory
tar (grandchild): <hosname>\:/usr/local/src/ssh-1.2.29.tar.gz: Cannot 
open: Input/output error
tar (grandchild): Error is not recoverable: exiting now

gzip: stdin: unexpected end of file
tar: Child returned status 1
tar: Error exit delayed from previous errors

Expected Results:  
drwxr-xr-x tri/operator      0 2000-07-03 13:08:15 ssh-1.2.29/
-rw-r--r-- tri/operator  13556 2000-07-03 13:06:51 ssh-1.2.29/COPYING
-rw-r--r-- tri/operator  22129 2000-07-03 13:06:51 ssh-1.2.29/README
-rw-r--r-- tri/operator   3914 2000-07-03 13:06:51 ssh-
1.2.29/README.SECURID
.....
.....
.....

the error begun when we upgrade the rmt package, from rmt-0.4b15-1 to rmt-
0.4b19-5.6 , in the new version the file /etc/rmt is moved to /usr/etc/rmt 
( FHS ?? ) so the quick solution to the bug is to create the link /etc/rmt 
--> /sbin/rmt as in the old rmt package.

Comment 1 Bernhard Rosenkraenzer 2001-01-31 23:13:37 UTC
Install the rmt package.

Comment 2 Roger Pena-Escobio 2001-02-01 00:26:08 UTC
the rmt package is installed but, i repeate, the /etc/rmt file doesn't exist, 
it was move to /usr/etc/rmt so tar can't work, you has to recreate the link in 
order to get the tar command working back.

Comment 3 Bernhard Rosenkraenzer 2001-02-01 00:36:04 UTC
rpm -qpl shows /etc/rmt is present both in rmt-0.4b15-1.i386.rpm, as shipped 
with 6.2, and rmt-0.4b19-4.i386.rpm, as shipped with 7.0. Make sure you're 
using our package.

Comment 4 Bernhard Rosenkraenzer 2001-02-01 00:37:22 UTC
Also, rmt is part of dump, not tar.

Comment 5 Bernhard Rosenkraenzer 2001-02-01 00:42:44 UTC
The problem is present in the 6.2 update package (0.4b19-5.6x); please fix

Comment 6 Mike A. Harris 2001-06-12 22:15:32 UTC
Fixed in rmt-0.4b22-1 in rawhide


Note You need to log in before you can comment on or make changes to this bug.