Bug 254118 - on x86_64 platform, not detect correct library (/usr/lib64 !)
on x86_64 platform, not detect correct library (/usr/lib64 !)
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: alltray (Show other bugs)
7
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Denis Leroy
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-24 05:44 EDT by Carlo
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-28 09:33:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Carlo 2007-08-24 05:44:10 EDT
Description of problem:
When use alltray on x86_64 platform machine, it use /usr/lib instead of /usr/lib64.


Version-Release number of selected component (if applicable):
This is the package alltray-0.69-2.fc6.x86_64.rpm


How reproducible:
Install sunbird (from Mozilla Foundation site) and open a shell (from anything
user) and write:
$ alltray -d sunbird
...
lib is here: /usr/lib       <-- !?!
...

and strangely it works.
But if I try to "create an icon run" from Gnome Desktop Environment it does not
work!
Perhaps the indication of /usr/lib in debug is corrected? Or not!


Steps to Reproduce:
1.With Gnome Desktop Environment, on desktop, click right mouse button and
select "create icon run..."
2."alltray sunbird" and save
3.Now run the new icon, but not work!
  

Actual results:


Expected results:


Additional info:
Comment 1 Denis Leroy 2007-08-28 06:10:01 EDT
The /usr/lib message is only displayed when ran in debug mode, and shouldn't be
the cause of your problem. Nonetheless I'll add a patch to fix that.

Can you describe in more details what you're doing to reproduce the problem
("create icon run"?  where is that ?) ?

thanks
Comment 2 Carlo 2007-08-28 06:40:54 EDT
Ok… first of all excuse for my English not much perfect one.
When click right mouse button (on desktop), is the second one chosen beginning
from the high.
From my language to the English language, i think it is translate "create icon
start ..." ?!

Well, if you find it, the third chosen is "command" ... write "alltray sunbird"
... click OK and run the new icon.
This not work. The sunbird icon not appear on systray.
Then I have decided to use the version to 32bit and works!

I hope to me it are explained this time well:)
Comment 3 Denis Leroy 2007-08-28 07:15:35 EDT
Ok, this works for me, although not with sunbird.

If you create launcher with 'alltray gnome-terminal' for example, does it work ?

If you create a launcher with sunbird only, does it work ?
Comment 4 Carlo 2007-08-28 08:00:35 EDT
If i create launcher 'alltray gnome-terminal': it work very well!
But, if i create launcher 'alltray sunbird' not work: open sunbird in "normal mode".
Why?

I have installed only alltray-0.69-2.fc6.x86_64.rpm (64 bit version) package ...
i must to install alltray-0.69-2.fc6.i386.rpm (32 bit version) too?
That is I must install both packages?

Comment 5 Denis Leroy 2007-08-28 08:20:41 EDT
Where did you get the sunbird RPM ? Is it a 32-bit or a 64-bit RPM ?
Comment 6 Carlo 2007-08-28 08:44:48 EDT
It is not a RPM ... i download it from Mozilla site:
http://releases.mozilla.org/pub/mozilla.org/calendar/sunbird/releases/0.5/linux-i686/it/sunbird-0.5.it.linux-i686.tar.gz
and i think that is an 32 bit version! :P
Ok, i think that now you say me to install also alltray 32 bit, right? ...
therefore it will work?
Comment 7 Denis Leroy 2007-08-28 09:04:32 EDT
Yes, that's most likely the reason. Alltray can't deal with both 32-bit and
64-bit app it would seem. Your best bet is then to install the 32-bit version.
Comment 8 Carlo 2007-08-28 09:16:31 EDT
Ok. Thanks of the time that you have dedicated to me.
… it was not a bug! :) … it's the first time that i have an 64 bit PC!
Thank you.
Bye
Carlo
Comment 9 Denis Leroy 2007-08-28 09:33:51 EDT
No problem :-)

Note You need to log in before you can comment on or make changes to this bug.