Bug 254160 - yum update fails rpm_check_debug vs depsolve
yum update fails rpm_check_debug vs depsolve
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
7
i386 Linux
low Severity low
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-24 11:01 EDT by Markus Armbruster
Modified: 2014-01-21 17:59 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-29 10:55:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Output of rpm -qa (21.10 KB, text/plain)
2007-08-24 11:01 EDT, Markus Armbruster
no flags Details

  None (edit)
Description Markus Armbruster 2007-08-24 11:01:01 EDT
Description of problem:
yum update fails me with 
ERROR with rpm_check_debug vs depsolve:

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. yum update
2.
3.
  
Actual results:
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package git.i386 0:1.5.2.4-1.fc7 set to be updated

Dependencies Resolved

=============================================================================
 Package                 Arch       Version          Repository        Size 
=============================================================================
Updating:
 git                     i386       1.5.2.4-1.fc7    updates           6.0 k

Transaction Summary
=============================================================================
Install      0 Package(s)         
Update       1 Package(s)         
Remove       0 Package(s)         

Total download size: 6.0 k
Is this ok [y/N]: y
Downloading Packages:
Running rpm_check_debug
--> Populating transaction set with selected packages. Please wait.
---> Package git.i386 0:1.5.2.4-1.fc7 set to be updated
ERROR with rpm_check_debug vs depsolve:
Package git needs git-svn, this is not available.
Package git needs git-cvs, this is not available.
Package git needs git-arch, this is not available.
Package git needs git-email, this is not available.
Package git needs gitk, this is not available.
Package git needs git-gui, this is not available.
Complete!


Expected results:
Package git is updated, and its dependencies installed.

Additional info:
Comment 1 Markus Armbruster 2007-08-24 11:01:02 EDT
Created attachment 172424 [details]
Output of rpm -qa
Comment 2 Seth Vidal 2007-08-24 11:15:47 EDT
could you try yum 3.2.3 from updates-testing?

Comment 3 Markus Armbruster 2007-08-28 05:37:41 EDT
I did.  Same result.  Anything else I can do to help?
Comment 4 Charles R. Anderson 2007-08-28 22:04:04 EDT
Same result for me with yum 3.2.2 and yum 3.2.3 from updates-testing.
Last working version was yum 3.2.1.
Comment 5 Seth Vidal 2007-08-29 01:00:21 EDT
try out 3.2.4, please.

also 3.2.1 didn't really work - it just didn't report the error :)

Comment 6 Markus Armbruster 2007-08-29 07:51:04 EDT
I built 3.2.4 from CVS (it doesn't seem to be in updates-testing), no improvement.
Comment 7 Seth Vidal 2007-08-29 08:15:37 EDT
okay - just one more thing.

run:

rpm -Va --nofiles --nomd5

and post any output, please.
Comment 8 Markus Armbruster 2007-08-29 09:34:23 EDT
# rpm -Va --nofiles --nomd5
Unsatisfied dependencies for autoconf-2.61-8.fc7.noarch: imake
Unsatisfied dependencies for git-1.5.2.2-1.fc7.i386: git-svn, git-cvs, git-arch,
git-email, gitk, git-gui
Comment 9 Jeremy Katz 2007-08-29 10:55:23 EDT
Aha, see what it is and have fixed it up.  You can fix by installing the
currently broken deps.

Note You need to log in before you can comment on or make changes to this bug.