This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 254168 - Intel GMA X3100 and OpenGL crash X Server
Intel GMA X3100 and OpenGL crash X Server
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-i810 (Show other bugs)
7
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-24 11:32 EDT by Martin Winkler
Modified: 2008-06-16 22:13 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-16 22:13:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
logfile which might help finding the cause of the crash (42.60 KB, text/plain)
2007-08-24 11:32 EDT, Martin Winkler
no flags Details
this is a Xorg log file which was next to the originally attached one, maybe it helps too. (42.60 KB, text/plain)
2007-08-24 11:34 EDT, Martin Winkler
no flags Details
xorg.conf of the affected system (nothing really changed from original installation) (930 bytes, text/plain)
2007-08-24 11:37 EDT, Martin Winkler
no flags Details

  None (edit)
Description Martin Winkler 2007-08-24 11:32:19 EDT
Description of problem:
When using an OpenGL-application like openarena, Google Earth or Beryl, the
X-Server crashes as soon as anything seems to be drawn off screen.

Version-Release number of selected component (if applicable):


How reproducible:
always


Steps to Reproduce:
1. use Beryl as window manager
2. start a terminal window
3. move it out of any edge of the screen.
  
Actual results:
X server crashes and is even unable to start again. (Not even the login screen)
It seems that the X server restarts over and over.

Expected results:
X server not crashing :-)

Additional info:

This behaviour occurs with my laptop, a Sony Vaio VGN-CR11S which has an Intel
GMA X3100 graphics card.

The computer is still accessible via ssh, so I am still able to do a "shutdown
-h now" from a remote computer.

I am attaching two Xorg.log files which might help you in finding the reason.

My system is Fedora 7, with all updates installed as of 2007-08-24.
Comment 1 Martin Winkler 2007-08-24 11:32:20 EDT
Created attachment 172427 [details]
logfile which might help finding the cause of the crash
Comment 2 Martin Winkler 2007-08-24 11:34:05 EDT
Created attachment 172428 [details]
this is a Xorg log file which was next to the originally attached one, maybe it helps too.
Comment 3 Martin Winkler 2007-08-24 11:37:03 EDT
Created attachment 172429 [details]
xorg.conf of the affected system (nothing really changed from original installation)
Comment 4 Martin Winkler 2007-08-27 05:42:07 EDT
I also tried it with the most recent xorg-x11-drv-i810.i386 2.1.0-1.fc7 driver
from fedora-updates-testing, but the X server still crashes when doing any
OpenGL stuff.
Comment 5 rizo83 2007-09-07 14:15:59 EDT
Try installing the updated mesa-libGL, mesa-libGLU and libdrm rpms from
http://people.freedesktop.org/~hughsient/fedora/7/i386/

It worked for me on an ASUS S62E w/ Fedora 7 x86
Comment 6 Martin Winkler 2007-09-07 19:24:16 EDT
Thank you riso83, this solved my problems too! beryl and openarena work well
now. Only googleearth does not: It is very slow and unresponsive. and at the
console, I see this message:
do_wait: drmWaitVBlank returned -1, IRQs don't seem to be working correctly.
Try running with LIBGL_THROTTLE_REFRESH and LIBL_SYNC_REFRESH unset.

I don't know what to do here, but I think that this is out of scope here - I'll
search the web for a possible solution of this last issue.

(I don't know whether I should close this ticket or not, so I leave it as NEW.
Maybe someone with more insight will close the ticket, or only at the time when
the packages are in fedora-updates?)
Comment 7 Matěj Cepl 2007-09-11 10:35:36 EDT
Yeah, I will pass this to developers. Switching to ASSIGNed.
Comment 8 Bug Zapper 2008-05-14 10:06:07 EDT
This message is a reminder that Fedora 7 is nearing the end of life. Approximately 30 (thirty) days from now Fedora will stop maintaining and issuing updates for Fedora 7. It is Fedora's policy to close all bug reports from releases that are no longer maintained. At that time this bug will be closed as WONTFIX if it remains open with a Fedora 'version' of '7'.

Package Maintainer: If you wish for this bug to remain open because you plan to fix it in a currently maintained version, simply change the 'version' to a later Fedora version prior to Fedora 7's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that we may not be able to fix it before Fedora 7 is end of life. If you would still like to see this bug fixed and are able to reproduce it against a later version of Fedora please change the 'version' of this bug. If you are unable to change the version, please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's lifetime, sometimes those efforts are overtaken by events. Often a more recent Fedora release includes newer upstream software that fixes bugs or makes them obsolete. If possible, it is recommended that you try the newest available Fedora distribution to see if your bug still exists.

Please read the Release Notes for the newest Fedora distribution to make sure it will meet your needs:
http://docs.fedoraproject.org/release-notes/

The process we are following is described here: http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 9 Bug Zapper 2008-06-16 22:13:51 EDT
Fedora 7 changed to end-of-life (EOL) status on June 13, 2008. 
Fedora 7 is no longer maintained, which means that it will not 
receive any further security or bug fix updates. As a result we 
are closing this bug. 

If you can reproduce this bug against a currently maintained version 
of Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.