Bug 254216 - radeon driver wakes up 60 times a second.
Summary: radeon driver wakes up 60 times a second.
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati   
(Show other bugs)
Version: 7
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Dave Airlie
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: wakeup
TreeView+ depends on / blocked
 
Reported: 2007-08-24 20:05 UTC by David Rees
Modified: 2007-11-30 22:12 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-05 01:49:39 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg.conf (882 bytes, text/plain)
2007-08-29 23:56 UTC, David Rees
no flags Details
Xorg.0.log (88.62 KB, text/plain)
2007-08-29 23:57 UTC, David Rees
no flags Details

Description David Rees 2007-08-24 20:05:27 UTC
Reporting as requested by
https://www.redhat.com/archives/fedora-devel-list/2007-August/msg00544.html

The radeon driver in xorg-x11-drv-ati-6.6.3-4.fc7 wakes up 60 times a second
when not doing anything. It looks like there is a patch floating around which helps:

http://lkml.org/lkml/2007/5/16/53

Comment 1 Adam Jackson 2007-08-27 21:03:17 UTC
That patch will break any attempt to sync swaps to vblank.

The right fix is more like "only enable the vblank interrupt when a buffer swap
request comes in that wants it".

Comment 2 Dave Airlie 2007-08-28 07:41:52 UTC
I think this should be in rawhide and working already... can you re-test it please?


Comment 3 David Rees 2007-08-29 23:54:57 UTC
OK, installed xorg-x11-drv-ati-6.6.193-2.fc8 from the development repo, but when
X is running the ATI Radeon card still generates 60+ wakeups a second. I will
attach the xorg.conf and Xorg.log as well if that helps.

Comment 4 David Rees 2007-08-29 23:56:20 UTC
Created attachment 180081 [details]
xorg.conf

Comment 5 David Rees 2007-08-29 23:57:47 UTC
Created attachment 180101 [details]
Xorg.0.log

Generated using:
xorg-x11-server-Xorg-1.3.0.0-9.fc7
xorg-x11-drv-ati-6.6.193-2.fc8

Comment 6 Dave Airlie 2007-08-30 00:43:02 UTC
you need a new kernel I just realised as well, this stuff is only gone upstream
for 2.6.23, radeon drm 1.27 isn't new enough to support this..

Comment 7 David Rees 2007-08-30 01:32:20 UTC
OK, I upgraded to kernel-2.6.23-0.74.rc2.git1.fc8 and now the system generates
about 45 wakeups/second sitting at the GDM login screen instead of well over
100. Looks a lot better!

Wakeups-from-idle per second : 46.0
Top causes for wakeups:
  41.4% ( 18.3)   at-spi-registry : schedule_timeout (process_timeout)
  30.1% ( 13.3)              Xorg : do_setitimer (it_real_fn)
   6.0% (  2.7)     <kernel core> : clocksource_register (clocksource_watchdog)
   3.0% (  1.3)                ip : tg3_open (tg3_timer)
   3.0% (  1.3)              ntpd : schedule_timeout (process_timeout)
   3.0% (  1.3)     <kernel core> : queue_delayed_work_on (delayed_work_timer_fn)

The next one on the list is known bug #227476.


Note You need to log in before you can comment on or make changes to this bug.