Bug 254217 - Corrupted mailbox list index file /home/foo/.maildir/dovecot.list.index.uidmap: dir_size is smaller than record count
Corrupted mailbox list index file /home/foo/.maildir/dovecot.list.index.uidma...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: dovecot (Show other bugs)
rawhide
All Linux
high Severity high
: ---
: ---
Assigned To: Tomas Janousek
Fedora Extras Quality Assurance
http://dovecot.org/list/dovecot/2007-...
:
Depends On:
Blocks: F8Blocker
  Show dependency treegraph
 
Reported: 2007-08-24 16:07 EDT by Nicolas Mailhot
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-27 16:00:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
my serveur setup (44.33 KB, text/plain)
2007-08-31 02:19 EDT, Nicolas Mailhot
no flags Details

  None (edit)
Description Nicolas Mailhot 2007-08-24 16:07:16 EDT
Upgrade to dovecot-1.1-16.1.alpha3.fc8.x86_64 results in a flood of error
messages in maillogs. Mail clients misbehave and hide old messages. Reverting to 
dovecot-1.0.2-13.5.fc8.x86_64 fixes the problem

imap-login: Login: user=, method=PLAIN, rip=, lip=, TLS
IMAP(): uid_validity mismatch in file /home//.maildir/dovecot.list.index.uidmap:
1187985334 != 0
IMAP(): Corrupted mailbox list index file
/home//.maildir/dovecot.list.index.uidmap: dir_size is smaller than record count
IMAP(): /home//.maildir/dovecot.list.index: Desync: uid_validity changed
1187985334 -> 1187985335
IMAP(): Disconnected bytes=74/412
imap-login: Disconnected: rip=, lip=, TLS handshaking

imap-login: Login: user=<>, method=PLAIN, rip=, lip=8, TLS
IMAP(): Corrupted mailbox list index file
/home//.maildir/dovecot.list.index.uidmap: dir_size is smaller than record count
IMAP(): /home//.maildir/dovecot.list.index: Desync: uid_validity changed
1187985335 -> 1187985337
IMAP(): Corrupted mailbox list index file
/home//.maildir/dovecot.list.index.uidmap: dir_size is smaller than record count
IMAP(): /home//.maildir/dovecot.list.index: Desync: uid_validity changed
1187985337 -> 1187985338
IMAP(): Corrupted mailbox list index file
/home//.maildir/dovecot.list.index.uidmap: dir_size is smaller than record count
IMAP(): /home//.maildir/dovecot.list.index: Desync: uid_validity changed
1187985338 -> 1187985339
IMAP(): Corrupted mailbox list index file
/home//.maildir/dovecot.list.index.uidmap: dir_size is smaller than record count
IMAP(): /home//.maildir/dovecot.list.index: Desync: uid_validity changed
1187985339 -> 1187985348
IMAP(): Corrupted mailbox list index file
/home//.maildir/dovecot.list.index.uidmap: dir_size is smaller than record count
IMAP(): Log synchronization error at seq=7,offset=588 for
/home//.maildir/dovecot.list.index: Append with UID 1, but next_uid = 2
Comment 1 Tomas Janousek 2007-08-28 09:40:47 EDT
Timo suggested using mailbox_list_index_disable=yes until he fixes the problems
with mailbox list index at http://dovecot.org/list/dovecot/2007-August/024828.html .

Other than that, I suppose Timo will look at your message about this bug, so
I'll leave this up to him.
Comment 2 Nicolas Mailhot 2007-08-28 18:01:48 EDT
The workaround seems to work, de-escalting to F8Target for now
Comment 3 Nicolas Mailhot 2007-08-31 02:18:30 EDT
unfortunaly, I was wrong, the workaround does *not* work

It seems the no-index setting is not 100% respected by dovecot, it still
regenerates the index after a while and once it's on-disk the problems restart
(BTW even if it worked it would be no real solution for fedora since even if it
worked dovecot will use indexes if present so you need to manually remove
indexes in user dirs in addition to setting no-index for the update to work… for
a while)
Comment 4 Nicolas Mailhot 2007-08-31 02:19:33 EDT
Created attachment 182741 [details]
my serveur setup
Comment 5 Timo Sirainen 2007-09-08 23:17:10 EDT
No, mailbox_list_index_disable=yes should completely disable dovecot.list.index*
file usage and creation.. I can't think of a way why it wouldn't work 100%.
Comment 6 Nicolas Mailhot 2007-09-09 03:33:09 EDT
All I can say is I did use this parameter, and the indexes were re-created after
a while regardless, and then all hell broke loose
Comment 7 Tomas Janousek 2007-09-25 09:35:10 EDT
I downgraded to 1.0.5, since stable enough a version isn't out yet and it's the
freeze date today.
1:1.0.5-1 should be in rawhide soon.
Comment 8 Nicolas Mailhot 2007-09-27 16:00:18 EDT
After a few days of testing this one seems more solid ; even if I did get some
imap-login segfaults when accessing imap tls dovecot through squirelmail (but
login again works and unlike the index problem no message is hidden from the
user when it should not be, so it's more an annoyance than a blocker)

Note You need to log in before you can comment on or make changes to this bug.