Bug 254341 - gfs-utils don't requires kmod-gfs
Summary: gfs-utils don't requires kmod-gfs
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: gfs-kmod (Show other bugs)
(Show other bugs)
Version: 5.0
Hardware: All All
low
low
Target Milestone: ---
: ---
Assignee: Chris Feist
QA Contact: GFS Bugs
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-08-25 16:56 UTC by Christian Jung
Modified: 2010-01-12 03:27 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-28 17:09:01 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Christian Jung 2007-08-25 16:56:27 UTC
Description of problem:
GFS-Utils don't have a dependency for kmod-gfs. Kernel modules for GFS2 are
included in kernel rpm, but kernel modules for GFS1 are missing.

Version-Release number of selected component (if applicable):
kernel-2.6.18-8.el5
kmod-gfs-0.1.16-5.2.6.18_8.1.8.el5
gfs-utils-0.1.11-3.el5

How reproducible:
always

Steps to Reproduce:
1. yum install gfs-utils
2. 

  
Actual results:
kernel modules for gfs are missing, mounting gfs filesystem fails

Expected results:
kernel modules should be installed because of dependencies

Additional info:

Comment 1 Chris Feist 2007-08-28 17:09:01 UTC
We don't require gfs kernel modules because there are activities you may want to
do without the kernel modules (ie. mkfs or fsck).

Closing as NOTABUG as this is the expected behavior.

Comment 2 Nate Straz 2007-12-13 17:42:43 UTC
Moving all RHCS ver 5 bugs to RHEL 5 so we can remove RHCS v5 which never existed.

Comment 3 Nate Straz 2007-12-19 20:07:00 UTC
Moving all closed bugs to gfs-kmod to match the rpm name.  GFS-kernel will be
removed.


Note You need to log in before you can comment on or make changes to this bug.