Bug 25440 - A packed enum bug.
Summary: A packed enum bug.
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gcc   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
high
high
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-02-01 00:45 UTC by Red Hat Bugzilla
Modified: 2008-03-13 19:18 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-01 00:46:05 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
A testcase. (824 bytes, text/plain)
2001-02-01 00:46 UTC, Red Hat Bugzilla
no flags Details

Description Red Hat Bugzilla 2001-02-01 00:45:10 UTC
The DAC960 driver uses packed enum. gcc 2.96 doesn't
handle it properly. egcs 1.1.2 is ok.

# gcc packed.c
packed.c:10: warning: width of `RamType' exceeds its type
packed.c:15: warning: width of `ErrorCorrection' exceeds its type
# a.out
4
zsh: 9887 abort      ./a.out

Comment 1 Red Hat Bugzilla 2001-02-01 00:46:02 UTC
Created attachment 8621 [details]
A testcase.

Comment 2 Red Hat Bugzilla 2001-02-06 17:05:39 UTC
This is fixed already since Feb, 2nd and the fix is in 2.96-74.
(but it is still waiting for approval for CVS head).


Note You need to log in before you can comment on or make changes to this bug.