Bug 254441 - Upgrade of FC5 crashes in depsolving
Upgrade of FC5 crashes in depsolving
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
7
athlon Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-25 16:39 EDT by Pierre Sarrazin
Modified: 2014-01-21 17:59 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-28 10:14:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Anaconda crash state, saved to a floppy (65.85 KB, text/plain)
2007-08-25 16:39 EDT, Pierre Sarrazin
no flags Details

  None (edit)
Description Pierre Sarrazin 2007-08-25 16:39:22 EDT
Description of problem:

I am trying to upgrade a Fedora Core 5 system to Fedora 7 using the DVD. At
first, the installer complained about the absence of labels on the devices in my
/etc/fstab ("Devices in /etc/fstab should be specified by label, not by device
name"). I used the e2label to assign labels to my filesystem partitions and then
edited fstab to reflect the changes. The fstab file thus went from this:

/dev/hda1       /               ext3    defaults        1 1
/dev/hda2       swap            swap    defaults        0 0
/dev/hda3       /usr            ext3    defaults        1 2
/dev/hda5       /var            ext3    defaults        1 2
/dev/hda6       /home           ext3    defaults        1 2

to this:

LABEL=slash     /               ext3    defaults        1 1
#/dev/hda2       swap            swap    defaults        0 0
LABEL=usr       /usr            ext3    defaults        1 2
LABEL=var       /var            ext3    defaults        1 2
LABEL=home      /home           ext3    defaults        1 2

(I commented out the swap space because I did not know what to do about that,
and the swap space seemed unimportant, especially since my PC has 1024 megs of RAM.)

On the next try with the F7 installer, it progressed to the boot loader
installation step. It said that my only option was to install a new one, which I
did not mind (there is only FC5 on this PC).

Then the installer crashed. I saved the state to a floppy, which I am attaching
to this report.  Here are the last several lines:

---------------------------------------------------------
16:07:18 ERROR   : failed to unlink /var/lib/rpm/__db.000
16:07:18 ERROR   : failed to unlink /var/lib/rpm/__db.001
16:07:18 ERROR   : failed to unlink /var/lib/rpm/__db.002
16:07:18 ERROR   : failed to unlink /var/lib/rpm/__db.003
16:07:18 CRITICAL: No Repositories Available to Set Up
16:07:18 INFO    : switching from CD [1] to 1 for 
16:07:49 INFO    : moving (1) to step postselection
16:07:49 INFO    : selected kernel package for kernel
16:07:50 WARNING : No package matched to remove


/tmp/lvmout:
    Finding all volume groups
  No volume groups found
---------------------------------------------------------

My system was freshly installed as Red Hat 5.1 in 1998 and I have upgraded it
ever since, mainly because it is a learning experience in itself. The system
seems to have sidestepped that whole volume group business somehow...

I am looking for instructions on how to create volume groups on my system, in
order to satisfy Anaconda. I strongly prefer to avoid a fresh install so as not
to spoil that streak I've got going on...


Version-Release number of selected component (if applicable):
Ananonda from "Core 7 x86 Install" DVD bought from CheapBytes.

How reproducible:
Only tried once.

Steps to Reproduce:
1. Choose upgrade
2. Have new boot loader configured

Additional info:

Fedora Core 5 system has been upgraded periodically through yum.

mount command displays this:

------------------------------------------------------
/dev/hda1 on / type ext3 (rw)
none on /proc type proc (rw)
none on /dev/pts type devpts (rw,gid=5,mode=620)
none on /proc/bus/usb type usbdevfs (rw)
/dev/hda3 on /usr type ext3 (rw)
/dev/hda5 on /var type ext3 (rw)
/dev/hda6 on /home type ext3 (rw)
none on /dev/shm type tmpfs (rw)
none on /proc/sys/fs/binfmt_misc type binfmt_misc (rw)
sunrpc on /var/lib/nfs/rpc_pipefs type rpc_pipefs (rw)
automount(pid2117) on /net type autofs
(rw,fd=4,pgrp=2117,minproto=2,maxproto=4)nfsd on /proc/fs/nfsd type nfsd (rw)
------------------------------------------------------

Current kernel is 2.6.20-1.2320.fc5.

The PC has a single 60 GB IDE hard disk.
Comment 1 Pierre Sarrazin 2007-08-25 16:39:22 EDT
Created attachment 172621 [details]
Anaconda crash state, saved to a floppy
Comment 2 Chris Lumens 2007-08-27 11:52:53 EDT
The message you're seeing about no volume groups found is not an error, just
informational.  The real error message is in the beginning of your exception
file.  Did you run media check on the DVD?  Otherwise, this looks like either a
yum problem or an interaction problem between anaconda and yum.
Comment 3 Pierre Sarrazin 2007-08-27 22:26:14 EDT
I ran a media check on the DVD and it passed.
Comment 4 Jeremy Katz 2007-08-28 10:14:36 EDT
This is caused by some old packages which don't have header fields yum is
expecting.  If you remove helptool, you should get past it (assuming you don't
have other similar packages).  This has been fixed in yum for the next release
Comment 5 Pierre Sarrazin 2007-08-30 22:18:26 EDT
Is there a way to use the rpm command to get a complete list of packages that
have the same characteristics as helptool?
Comment 6 Pierre Sarrazin 2007-09-08 13:28:58 EDT
Having found no way to determine a complete list of such packages, I used rpm
-qi --all to detect all packages installed before 2001, and uninstalled most of
them. The upgrade went well after that, at least concerning the RPM upgrades.

Note You need to log in before you can comment on or make changes to this bug.