Bug 25471 - whitespace after digits confuses config parser
Summary: whitespace after digits confuses config parser
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: logrotate   
(Show other bugs)
Version: 6.2
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Erik Troan
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-02-01 11:47 UTC by Jarno Huuskonen
Modified: 2007-04-18 16:31 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-01 11:47:57 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jarno Huuskonen 2001-02-01 11:47:54 UTC
If logrotate.conf has a line like 'rotate 5 ' (without the ' chars)
logrotate complains that '5 ' is bad rotation count.

The problem seems to be in config.c use of strtoul to parse the value.

Reproducible: Always
Steps to Reproduce:
1. add space after rotate 'number' to logrotate.conf
2. try to run logrotate
3.

Comment 1 Erik Troan 2001-02-01 18:17:42 UTC
This is fixed in the latest logrotate


Note You need to log in before you can comment on or make changes to this bug.