Bug 25472 - Bad: Installer crashed before extract RPM files to the hard disk after format the hard disk
Bad: Installer crashed before extract RPM files to the hard disk after format...
Status: CLOSED DUPLICATE of bug 18032
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-01 06:48 EST by LinYunling
Modified: 2007-04-18 12:31 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-01 11:38:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description LinYunling 2001-02-01 06:48:39 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT 5.0)


I want to install the RedHat7.0 in my computer,
but the installer crashed after format disk before extract
RPM files to my hard disk.

Reproducible: Always
Steps to Reproduce:
1.Insert the RedHat 7.0 CDROM into my computer
2.Reboot the computer and boot from CDROM
3.use RedHat 7.0 GUI Installer
4.choose "English"
5.choose Keyboard & Mouse type
6.choose "Custom" method
7.choose the partition where the RedHat7.0 want to install
8.choose don't create boot disk and install lilo into Super Block
  and select the software that I want to install
 and press my password and create the normal account
10.Installer format the partition and say "Prepare to install..."
11.Installer crashed
	

Actual Results:  Install crashed and report "it is a bug".

Installer output like this:

Traceback (innermost last):
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/iw/progress_gui.py", 
line 20, in run
    rc = self.todo.doInstall ()
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 1480, in 
doInstall
    if self.method.systemMounted (self.fstab, self.instPath, 
self.hdList.selected()):
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/image.py", line 46, in 
systemMounted
    self.loopbackFile = mntPoint + fstab.filesystemSpace(mntPoint)[0][0] + 
\
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/fstab.py", line 258, in 
filesystemSpace
    space.append((mntpoint, isys.fsSpaceAvailable(topMount + '/' + 
mntpoint)))
  File "/usr/lib/anaconda/isys.py", line 16, in fsSpaceAvailable
    return _isys.devSpaceFree(fsystem)
SystemError: (2, 'No such file or directory')

Local variables in innermost frame:
fsystem: /mnt/sysimage//c

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iimage
CdromInstallMethod
p4
(dp5
S'progressWindow'
p6

<failed>

My computer:
  CPU:           PIII 550E
  motherboard:   Asus P3V133
  Display Card:  Asus V3800pro(TNT2pro)
  Monitor:       ViewSonic GT775
  Memory:        Kingmax PC133 128M
  Sound Card:    Sound Blaster 16
  CDROM:         Asus 40x
  Hard Disk:     1. IBM 30G(DMA66. 7200 & 2M Cache)
                 2. Qutaum BigFoot II 4.3G
Install RedHat6.2 success.
Comment 1 Michael Fulbright 2001-02-01 11:38:47 EST
Fixed by an errata on the Red Hat website.

*** This bug has been marked as a duplicate of 18032 ***

Note You need to log in before you can comment on or make changes to this bug.